#x-studio365, a game development tool based on Cocos2d-x

#x-studio365, a game development tool based on Cocos2d-x
0.0 0

#64

thanks for your feedback.
Currently, you can use Ctrl+O to open a generic text file or binary file.
I will Add the missing menu item “Open File”.
I will check the physics editor later.


#65

Hi, gplayers, I have sent a email to you.


#66

x-studio365 specific engine:
github.com:
engine: https://github.com/halx99/cocos2d-x
3rd libs: https://github.com/halx99/cocos2d-x-external

git.oschina.net:
engine: http://git.oschina.net/halx99/cocos2d-x
3rd libs: http://git.oschina.net/halx99/cocos2d-x-3rd-party-libs-bin

Usage: clone the engine and 3rd, then copy or move all 3rd libs files to engine_root/external folder.
currently, the build & run system have tested on win32&android, iOS have not test yet.

remark: VS2015 is required.


#67

Hi,
great job so far. I have a little problem, when I place a particle system, in the editor the position is changed when I load the published file in cocos. I think it has to do with the anchor point of the particle system.
This is how it should be:


But this is how is seen when loaded in cocos:

As you see, both particle system are off


#68

Thanks for your feedback, could you upload this demo, let me check the what happy?


#69

Hi,
This is the project from x-studio
TestProject.zip (838.3 KB)
And this is the code I’m using to load the scene
TestGameCocos.zip (1.6 MB)


#70

I have a question, you publish with reader 10.0.2100, but load with 2.0.0.0?


#71

Hi,
Actually I tried loading with 2.0 which I think is the reader20 folder, with 2.1 which should be the reader21 folder and with the one that is inside the cocosstudio folder wich I suppose is the 10.0.2100 reader. But not of them work


#72

I have test, it’s seems ok:



#73

This is odd, Have you changed anything in the code, or are you using a different version of the editor (I’m using the last that is available for download) ?. What do you think it could be?, Maybe I messed up with something in cocos?
For me is incorrect.
Editor:


Cocos:
Maybe I should try to reinstall cocos


#74

I think I find the root reason of this bug, it’s caused by engine internal bug, the latest official engine also has this bug, for detial, please see: https://github.com/cocos2d/cocos2d-x/pull/18002


#75

Hi,
Your fix solved my problem.
Thanks a lot


#76

You are welcome.:grinning:


#78

I guess we need Import whole folder also if we have pasted all assets in assets folder we should be able to import the whole folder too. And changing scene name causing issues, sometime its even remove all items inside scene.
check out this link : https://youtu.be/7Ee74o8vLkM

another new .plist error video link : https://youtu.be/25-66z2TsX8


#80

thanks for your feedback, I will check later.
by the way, when you importing spritesheet .plist, please don’t select the .png file, just select .plist file.


#81

AAH!,I got it. Thanks for your reply. found the solution …the .plist file which is packed by other tools like ‘shoebox’ works perfect and allows us to pick each sprite as separate too. Only packed from cocostudio .plist files r not working thats fine it doesn’t matter to improve. its working.

*** Enable the intellishader dont saves the adjusted parameter and not even exported to cocos2dx .csb file. it renders as it is default sprite somehow.


#83

Actually, The intellishading is a experimental feature currently, I don’t confim does it really necessary, currently it’s not saved and not exported to .csb file.
If you need this feature, I will add it later, it’s need integrate a little runtime to engine .csb reader.


#84

Oh, I see. Actually its very important feature you have developed. With that we can avoid the rendering drawCall of lots of sprites separately on gpu. which helps to save performance. and neither we have to spent time to create it. so it saves lots of time too. If you can finalize in the reader for the next version it will be really ultimate useful.


#85

OK, I will complete this feature later.


#86

Hi, gplayers
I chould not reproduce the double times import problem.
Chould you provide a simple demo project for this bug?