(Updated: v3.13.1 update released) Cocos2d-x v3.13 released!

(Updated: v3.13.1 update released) Cocos2d-x v3.13 released!
0.0 0

#22

Compare to V3.11, The font color in 3.13 is changed which created by cocos studio. It looks ugly.
It seems that 3.13 is lost supporting cocos studio.


#23

Where are you looking for these docs?


#24

This has been fixed and a v3.13.1 will be released.


#25

i have a problem to compile this version on a linux 32bit version… it said that sqlite3 and chipmunk are missing… i add it my self but i got a lot of errors with the chipmunk lib… i notice that there is no precompiled lib for the 32bit chipmunk in the external folder of the engine… is this an error?


#26

I have only really tested on 64-bit Ubuntu. IIRC I was seeing 32-bit errors, but I don’t recall what they were off hand.


#27

What is the most stable verson of Cocos2dx that starts with version 3?


#28

Use v3.13. If you go back to previous versions those will have less functionality and who knows what nuances. This is software, every version needs improvement.


#29

hii ,
can someone explain about “$(call import-module, android/cpufeatures/prebuilt-mk)” line in prebuilt-mk/Android.mk , my cocos compile returned error 2 , but after i remove that line the compilation run perfect , FYI i use gen-libs -p android


#30

Thanks. I tried the latest v3 branch but noticed it wasn’t fixed yet in that one. So I should probably get the v3.13.1 branch?


#31

Can’t use sdkbox with ver 3.13!


#32

yup. v3 gets branches merged into it after release.


#33

care to elaborate?


#34

I tried to upgrade my project from 3.4 to 3.13 currently, at 3.4 I can build both c++ and java with “build” button in eclipse, but in 3.13 it lacks the script for eclipse to build c++ side. can I just run “coco compile” to build c++ file first and then use eclipse “build” button to modify and test my java code? and can I still use eclipse to export signed apk once I already run “cocos compile”?


#35

Windows-7, C++, migrate from 3.10; compile for Win32, Android; running on Win-7 and Android 4.4.2 device; steps:

  1. Python update: passed, no restart.

  2. Cocos check: “>cocos -v” gives:
    “cocos2d-x-3.13
    Cocos Console 2.1” - seems passed.

  3. New project creation: passed, but seems there is no binary template :frowning: -> too heavy project, too long (first?) build.

  4. Console build have created “unique.apk” file, I copy it manually to my device, click to install - passed, then click “Run” - device says something like “seems there is a conflict with this app previous version” - impossible - it was very new.

  5. Console run - passed, after that I compare both apk - no difference; uninstall app, install old-bad “unique.apk” (it was still on device) - installed and runned manually ok.

  6. Applying “proj.visualstudio”, then opening properly both “proj.win32.sln” and “proj.visualstudio\Cocos2d.sln” - passed.

  7. Editing cpp file (unicode text) in VS-2015, then compiling/running it via command prompt on device - passed, createWithTTF(“1 qwe йцу ąčę”) shows English text and boxes for other encoding characters (йцу ąčę).

  8. Compiling/running “proj.win32.sln” for Windows-7 - passed, but unicode text displayed wrong:
    createWithTTF(“1 qwe йцу ąčę”) are not displayed at all;
    createWithTTF(“1 qwe”) - shows ok;
    createWithSystemFont(“2 qwe йцу ąčę”, “Arial”, …) - shows “2 qwe ??? ???”. cocos-v.-3.10 displayed it properly on Windows-7.

  9. Compiling/running “proj.visualstudio\Cocos2d.sln” for Android - failed - setting not set properly by me.

Migration reasons:

  1. I wanted full-screen app on android device - I have it, but navigation bar appears and does not disappear after I push physical “volume up/down” buttons on my devise. BTW navigation bar hides cocos app “exit” button.
    Adding
    @Override public void onWindowFocusChanged( ... glSurfaceView.setSystemUiVisibility( ... Cocos2dxGLSurfaceView.SYSTEM_UI_FLAG_HIDE_NAVIGATION ...
    into “AppActivity.java” haven’t helped, but has freezed the device once (not reproduced).
    App was re-started many times successfully - it was crashing after the same actions, whrn built with cocos-v.-3.10.

  2. Going to check how it works with turn-based-multiplayer via Google-Play-Services - on 2014 “Wagon War” … soon.


#36

Dear all,

Firstable, thanks for this new version !

But I have a problem when I tried to create the visual studio Android projects (described here : https://blogs.msdn.microsoft.com/vcblog/2016/07/12/cocos2d-x-visual-studio-android-project/#comment-166585)

  1. When I try to create it with android api 19 (KitKat 4.4), I have these errors on the cpp project :
    libcurl.a(libcurl_la-netrc.o): In function `Curl_parsenetrc’:

netrc.c:(.text+0x246): undefined reference to `getpwuid_r’
=> It seems that the new CURL library uses this getpwuid_r function, which is not available in API 19… That’s the problem ?

  1. Since I saw this function is available from android API 21 (Lolipop 5.0), I tried to create the projects with this API version… But in API 21, there is a problem on the APK generation project when compiling Cocos2dxDownloader.java :
    Cocos2dxDownloader.java:15: error: DataTaskHandler is not abstract and does not override abstract method onFailure(int,Header[],byte[],Throwable) in BinaryHttpResponseHandler
    11> [javac] class DataTaskHandler extends BinaryHttpResponseHandler {
    => It seems that BinaryHttpResponseHandler has not the same interface in API 21 ? (I’m not a java specialist, sorry if I made a mistake :stuck_out_tongue_winking_eye:)

Can somebody help me to solve this problem ? (note that I’d prefer to use the API-19…)

Thanks :sunglasses:


#37

can you ensure you are using v3.13.1 and not just v3.13?


#38

Thanks a lot ! I did not see this 3.13.1 release (since when was it on http://www.cocos2d-x.org ?)

I will do a new try with this version and I will tell you !

(note that since this morning I did a last try with android api 23… And it worked (with cocos2d-x 3.13) !)


#39

It was released within the last few hours.


#40

I just retried with v3.13.1 and it is the same problem with API 19 :sob:

But OK, I made this try with VS 2015, but when a project is compiled with android studio, how can it work with API-19 since one of the functions which is not found (getpwuid_r, because there are 2 or 3 other functions which are not found) is called by libcurl and does not exists too !

Can somebody help me ?

I will try to find by myself in parallel… :disappointed_relieved:


#41

Just FYI, v3.13.1 has now been released. Fixes bugs in Label, Android API, Audio, etc.

https://github.com/cocos2d/cocos2d-x/blob/v3.13.1/docs/RELEASE_NOTES.md#bug-fixed