Cocos2d-x v3.11 released!

Cocos2d-x v3.11 released!
0.0 0

#61

I believe it can work, if you create a 3.11 project using console, develop your assets separately in studio and import the studio exported resources to your project. Version 3.11 still has the APIs necessary to read studio exported assets, it’s just that the didn’t rebuild studio to be able to use 3.11


#62

and we also did not test Studio and v3.11.


#63

Yes, it is a problem with NDK r11c. It works with NDK r10e, I have met the same issue.


#64

@zhangxm says he uses r10c for everything and it should work with v3.10 and v3.11.

Edit, oops, r10c, per @zhangxm


#65

V3.11.1 has now been released! This fixes issues generating the pre-built libraries and we now support ipv6-only networks


#66

@zhangxm Would you be so kind to explain how to configure the ndk r11c?


#67

@slackmoehrle I used r10c, not r11c. There is an issue in r11c with JSB projects, i created an issue here: https://github.com/cocos2d/cocos2d-x/issues/15739


#68

In V3.11 & V3.11.1 cpp theris a bug! When application goes to background and then returns, it looks like scale and position off images become wrong! To test this, just make win32 app with fullscreen
glview = GLViewImpl::createWithFullScreen("test");
and then make alt+tab to go to background and then return to the app. V3.10 dont have this bug


#69

Just tried to deploy WP app using updated cocos2d-x 3.11.1
Still not work, the include curl library does not pass the microsoft certification phase

“The API is not supported for this kind of Application - Api=inet_pton. Modulo=ws2_32.dll. File=libcurl.dll.”


#70

What bout r11c and C++? Is it ok?
NDK r11c and SDK android-23 is OK?


#71

hey!

cocos2dx 3.11.1 win32 doesnt build.

I created a new project and i get the error cannot open libcocos2d

Then i went back coocs2dx 3.9, created a new project and it worked without any problems

Thanks


#72

hmm, interesting. Did you use cocos new ... to create the new project?


#73

Cocos2d-x is use original engine source for compile as a default until v3.10. If you want to create prebuilt project(like previous versions), you need to add “-t binary” tag in the “new…” command.


#74

I’ll update the cocos command-line doc to reflect this as an example specifically.


#75

yes i used cocos new for athe new project


#76

@caf_max Yep, it is fixed in this PR, will be included in next version.
@Dalmax I think you can trace this issue.
@CrazyHappyGame There is an issue NDK r11 compiling error with JSB projects.


#77

Hi @zhangxm , Thanks!
yes the reported issue is the same as mine.
I have to try (as a quick/dirt fix) to replace the curl lib using the one present in cocos2dx 3.10 (which were working fine).


#78

Looks like the download doesn’t include “cocos2d-console”


#79

It is here for me…


#80

OK yes! It’s in the link above, but it’s missing from the GitHub release. (which I acquired by downloading the 3.11.1 zip from here: https://github.com/cocos2d/cocos2d-x/releases)