Cocos2d-x v3.11 released!

Cocos2d-x v3.11 released!
0.0 0


@larsven I’d make a GitHub issue out of this so we can have someone look at it.


OK it is not as bad as I thought
I am now hitting the assert in

float Node::getRotation() const

CCNode#rotation. RotationX != RotationY. Don’t know which one to return

Did not used to have this problem. The graphic test also hit this assert.

Not sure where that come from. I been trying to find out with no luck.
It is odd since I only use setRotation.

Also the pump in my program is much more jerky then it used to be. I will try to adjust the parameters.

Good luck


This is most likely the same issue:


Thank you!


Thank you for fixing TURNING event on PageView in 3.11, but I still have problem with PageView. When I remove page or all pages from PageView and then add new Page/s I cant set current page index. If I set any existing index PageView show me the last page, and set page index also to last. Maybe I do something wrong or this is a bug, can anybody explain it to me. Thank you!


Just tried to publish my updated windows-phone platform app (with cocos2d-x 3.11) on windows store, but it fail the certification for a not supported API:

“The API is not supported for this kind of Application - Api=inet_pton. Modulo=ws2_32.dll. File=libcurl.dll.”

I am not sure the english message would be using exactly these same words, because the Windows Certification Kit gives me output in italian (sigh).

Some other one tried to publish a windows phone app with the same error?
Thank you!


Hi, i downloaded 3.11 run setup command it is working fine, but when i want to create new project by this command “new MyGame -p com.your_company.mygame -l cpp -d NEW_PROJECTS_DIR”
it is not working it gives this message ‘new’ is not recognized as an internal or external command,
operable program or batch file. I am working on Windows 8 machine.How can i create new project using cocos2dx-3.11.


you forgot the cocos part of it.

cocos new MyGame -p com.your_company.mygame -l cpp -d NEW_PROJECTS_DIR


Hi, i tried with cocos like you said but still not working it says “‘cocos’ is not recognized as an internal or external command, operable program or batch file.”.The same thing is working for 3.10 and old 3.x version, but not with 3.11.


Then your PATH is not correct.

or, if you cloned from GitHub, you need to run git submodule update --init and probably for good measure.


Hi i just downloaded this version of the engine i setup all the enviorement (for android) and then i tried to complite the cpp-test for android… i follow all the steps in the programers guide but when the compiling process begin i got an error, it said:
Unable to find .cocos-project.json
the engine for some reason search for this file in a wired directory diferent from my wokspace.
my workspace is somethng like D:\Program Files\Cocos2dx\cocos2d-x-3.11\build but it search in this directory: D:\Program.cocos-project.json

im using ndk r11c , apache 1.9.7, JDK 1.8.0_92 and of coourse de Android SDK and phyton.


Yes it was PATH issue now it is resolved. Thanks


anything about my problem? and thanks in advance


Is the cocos installer v3.11 coming anytime soon?


You can go ahead and just create this file in your project root.

Have it contain something like:

    "engine_version": "cocos2d-x-3.10",
    "project_type": "cpp"


I am not sure yet. I will inquire about this during our weekly meeting. I will follow-up.


ok Im having a problem with my NDK_ROOT variable, when i run and i add the ndk root path it says that it is wrong… i dont know if is a problem with ndk r11c.
Im on Windows 7


Since this version didn’t come with an update of Studio, is there a way to create a Cocos Studio project using v3.11? When trying to create a C++ project using Cocos, I can only select v3.10, that was the last version that came with studio.

Also, when creating a new project, will the sdks that I will choose and download via Cocos tool work? Are they still compatible with the current Cocos tool and engine version?



at this time, yes.


Why can’t be 3.11 with studio as well? Since cocos creator is not for c++ yet. in 3.11 there are just lib updates so I can’t understand why can’t it work.