Blend mode Additive not working on iOS 14

Hello,

When adding sprites with the following blend:
source: SRC_ALPHA
destination: DST_ALPHA

Every thing looks normal. However on iPhoneX (iOS 14+) there is black pixels instead of alpha transparent.

The effect I am trying to achieve is blend mode: Additive.

Please help… thanks.

1 Like

Hi, what version of Creator are you using? Which platform? Can you provide a demo that reproduces the problem?

Just figured out that this post is duplicated…

Please follow the exact same issue here:

1 Like

@yufang.wu

Hello again…

I create a 10 by 10 combination of all types of blend mode (combined src with dst) on creator 2.4.3.

Here is how blends looks like in all devices:

However, if you look at it on iOS 14 you will get something different!

@hananht Maybe you can refer to this post: https://discuss.cocos2d-x.org/t/fix-ios14-bad-performance-on-browsers-webview-solved/51502/10

1 Like

@yufang.wu
I already did it. It fixed only runtime performance (I have lots of spines animations which dropped the performance).

However, it did not fixed the blending issue :frowning:

Any suggestions?

Can you provide a demo that reproduces the problem?

Here you go… @yufang.wu
Blender.zip (2.0 MB)

I am using CC 2.4.3 (latest). You should see that everything looks fine on all devices except for devices with iOS 14 and above.

I tested it with browserstack simulator and my fiends who has iPhone X and XS with iOS 14.

The error does not occure on CC 3 tech-preview.
Any advice?


This seems to be an iOS issue, I tested it with a new emulator and didn’t encounter this problem.

@yufang.wu @huanxinyin

Please try on a real device. You should see the difference on iOS 14 (latest version).

I still see the results on couple of iOS devices.

It work OK on real device iOS 14.2, what xcode version you working on? Can upgrade? Try it.

@huanxinyin

Amazing how is it working on your side?
I checked on multiple iOS 14 with the latest versions and it works horrible :frowning:

I will investigate again. My friends have iPhone X and XS. I will check agsin and let you know.

I checked on multiple devices with iOS 14 and the issue is still their.
You can use browserstack to test it yourself if you dont have those devices.
iPhone X, XS, 7, 6

My test device is iPhone 7 Plus, and I download a new mac version and test again, It still run OK,has you custom the engine?

I asked from a friend to make a record on his iPhone 8+.
Also, if you use browserstack you will see the same anomaly.

What is your CC version? I am using 2.4.3
Maybe their was a silent update or something?

Hi, Change engine default setting of cc.macro.ENABLE_TRANSPARENT_CANVAS, it will run ok.

@huanxinyin It still not working… :frowning:

How does the blend show after change the code? Maybe global code effect late, try to change engine source.

@huanxinyin I changed the engine source and I also validated that the parameter is true before even the firt componenet launched.

Still, no luck I am affraid.