Updating Ads & Firebase Analytics plugin causes incompatible version error

Updating Ads & Firebase Analytics plugin causes incompatible version error
0

All my SDKBOX imports are on version 2.5.1.0, and I am now getting the following error:

Terminating app due to uncaught exception ‘FIRAnalyticsVersionMismatch’, reason: 'Google Analytics for Firebase version (60001000) does not match with Google App Measurement (60101000) version. Please update.

I couldn’t easily find where I could download these versions manually to downgrade/upgrade, is there an easy way to fix this? (The reason for me wanting to update is that the version I was using is showing Modal interstitial ads which have to be swiped to dismiss, this was fixed by Google in a future sdk update which is not present in my current version of SDKBOX)

If you are using iOS Admob sdk GoogleMobileAds.framework with SDKBOX firebase, dont add GoogleAppMeasurement.framework to your project as there is same GoogleAppMeasurement.framework under SDKBOX.

you can find them at proj.ios_mac/Firebase/Analytics

That’s my point, I didn’t import anything manually, sdkbox did it for me.

I got you, i’m fixing this issue.

plz copy

firebae / admob iOS SDK use the same framework on staging server currently. plz try:

sdkbox update --staging

thanks,