[Solved] Moved bitmap font images away from the same folder, now my project won't load

[Solved] Moved bitmap font images away from the same folder, now my project won't load
0.0 0


I’m using Cocos Creator 1.7 and the luacpp plugin, if that’s relevant at all.

I have a folder in assets called fonts with a few different fnt and image files. Since I couldn’t filter between the images and the fonts in the UI, I wanted to move the bitmaps into another folder so that I could only see the font files when I was trying to drag them onto labels. Then, naturally, all my BMP fonts failed, so I moved them back, first through the Windows File Explorer, then back into the Creator. Then the fonts wouldn’t load, something about an invalid sprite frame.

Then I git stashed everything (which now seems like a bad decision) and now I’m getting duplicate UUID errors and my assets listing in the UI is empty: https://i.imgur.com/yT65JfV.png

In the image, you can see a scene I had going, with the fonts on ‘Options’ and ‘Achievement’ now reverting to a system font, the assets list showing nothing but the folders without anything inside them, and you can see in red where I tried to drag the base_scene asset back into the asset list on the left when it threw the error about duplicate UUID.

I’ve tried restarting Cocos Creator in the hopes that it would recognize the files that are still in the actual assets/Scene, assets/Textures etc folders but nothings helping. I’m worried that I’ll need to do a few dozen scenes and assets from scratch again. I’m currently installing Creator 1.8.1 to see if that helps at all.


Upgrading to 1.8.1 doesn’t change anything, still busted.

edit: After copying files around for a while and removing all *.fire, I saw I duplicated the Scene folder into New Scene, which had the same UUID and Creator couldn’t deal with two matching UUIDs, I deleted the New Scene duplicate folder and that solved the problem.

The reason this happened when I moved my fonts was that in my rush to undo the font moving, I hit Ctrl+R which reloaded my project, which must have scanned the new New Scene folder and then silently failed. Saw in the console what happened and worked it out.

tl;dr I copy pasted a folder in the assets folder, refreshed the project, creator didn’t like the duplicated folder and stopped loading; removing duplicate folder fixed it.


Did you have duplicate prefabs in there or something? You should probably let them know on github if you think it’s a bug.