Sdkbox admob not working with Cocos2dx 3.16 C++ Android

Sdkbox admob not working with Cocos2dx 3.16 C++ Android
0

I have a project in cocos2dx 3.16 version, I tried to update sdkbox, but I got lots of errors about duplicate class… later I created new project in cocos2dx 3.16 and tried adding sdkbox-admob. It showed some installations steps failed. .jar files were there in app/libs folder but not in the cocos/platform/android/java/libs folder. I followed the manual steps and put the .jar files in the engine folder java/libs and libcocos2dx/libs folder after that it says Platform sdkbox.admob.adunit is already there.
What should I do now? If I do not put the .jar inside engine folder then apk build finishes but ad doesn’t show up. It shows errors in logcat “admob plugin admob init native fail”.
I tried several times making new project and importing sdkbox-admob but it’s not working with the Cocos2dx 3.16 c++ & sdkbox-admob_v2.5.1.2.
Please help.
Thanks.

We can ask @yinjimmy to review this topic.

That means your sdkbox_config.json file is invalid. need to be json format.

plz put jars into project/app/libs folder.

may i have your APK to check ?

Thanks for your reply but I got it solved.
I created new project and tried again.

The problem is no matter how much I took care of everything like sdkbox.json, manifest.xml, build.gradle and .mk files, with the latest skdbox I always got “some installation steps failed” message, so I followed the manual steps from the docs.
There putting .jar files in “cocos/platform/android/java/libs” is suggested but with the new sdkbox version there seems no longer needed like previous versions.
Because of all of these I have to try couple of times creating new project folder.

Please I request to update the sdkbox docs/implementation guides of all the plugins.
Thanks.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.