Program type already present: com.sdkbox.plugin.AdMobUnit

Program type already present: com.sdkbox.plugin.AdMobUnit
0

I have integrated Admob through sdkbox, it was working fine. Recently I updated sdkbox but getting this error while building:
Error: Program type already present: com.sdkbox.plugin.AdMobUnit
How can I solve it? Is there any way to clean sdkbox?
Creating again a new project is too much hassle. Please help.

you can use command to find jar:

find /path/to/project/ -name "*.jar"

to find jars, check whether multi same name jar.

Yes I checked. PluginAdMob.jar file is in these 2 folders:
cocos/platform/android/java/libs/PluginAdmob.jar
cocos/platform/android/libcocos2dx/libs/PluginAdmob.jar
But it’s normal right? I couldn’t find any same .jar file in same folder.

whats your cocos2d-x game engine version?

plz remove the old PluginAdmob.jar .

Cocos engine version 3.16
Language c++

No those are not older version. I updated through SDKBOX update command.

Couldn’t find the duplicate jar files but it gives that error while building.

~/test/cpp316 [master] $ find . -name "sdkbox.jar"
./proj.android-studio/app/libs/sdkbox.jar
~/test/cpp316 [master] $ ls ./proj.android-studio/app/libs/
PluginAdMob.jar     PluginSdkboxAds.jar Plugingpg.jar       sdkbox.jar

plz try to put the sdkbox and plugins’ jar into ./proj.android-studio/app/libs/ folder.

PluginAdMob.jar
sdkbox.jar
android-support-v4.jar
These .jar files were already in the app/libs folder. But I couldn’t find Plugingpg.jar anywhere. I even downloaded admob plugin manual integration files, I couldn’t find that there either.

I’m using Android Studio 3.5, seems there is problem with Android Studio 3.5 and Cocos 3.16.
I tried to create new project with cocos new command. And I tried opening the project in Android Studio, I can’t see cocos project as Module there. With command line it works but in Android Studio run/build/compile doesn’t work because no Module there. Strange!!!
Now I have no option to create new project and integrate SDKBOX Admob again. :frowning
Now I’m really worried.

from plugin sdkboxads and gpg, plz ignore them.

try Android Studio 3.1 or 3.0? maybe 2.x .

plz post the whole compile error message.

plz try clean and rebuild.