[Paid] Update Cocos Creator 1.6.2 up to 2.4.2 (incl. XCode and Android Studio)


I have a project that I developed under Cocos Creator 1.6.2 – and I need it to get to running (and compile to XCode and Android Studio, and those also compiling) under the current version. It runs into multiple errors and warnings.

I’d be willing to pay $200 to the person who makes this happen. I’d send you a .zip file with the non-working project, you’d send me one back that will

  • compile and run in the simulator.
  • export successfully to XCode
  • compile and run successfully from within XCode
  • export successfully to Android Studio
  • compile and run successfully from within Android Studio

… all this with the current versions of the IDEs/APIs. It’s an ‘upgrade to the present’ for my project.

I’d need you to sign an NDA first, of course, as I’d have to send you the project package of my app.

Please be in touch: fabian@hemmert.eu


can you explain what trouble you are having? I haven’t heard of anyone needing to pay to upgrade Creator versions.

Hello! Thanks for looking into this. My project just starts to throw lots and lots of errors after I upgraded CC to 2.4.2…

Here’s my current log. I have no idea where to start.

Again, thanks alot!

1 Like

Let me talk to engineering.

Engineering said you are using python 3 and you need to be using python 2

[WARN]: ‘cc.url.raw’ is deprecated, please use ‘cc.resources.load’ instead.

Besides that, you also didn’t even follow the porting instructions on cocos website!

Look, being honest, as slackmoehrle said, porting should be simple, simple enough to not needed to be paid, but when is not, boooy is trouble! I’m finishing the port process in my company’s project, but the hole process started 5 months ago! And will not go out the same way that it was! So, is either too simple, or too complicated, and 200 USD only would pay the first one.

Thanks for looking into this!

I think we might be getting there.

  • I switched to Python 2.7.13
  • I followed the upgrade guide

Now, the whole thing throws these errors – it’s trying to load something, and I can’t figure out what (and why it doesn’t work):

Any ideas are appreciated!


(Also, this seems to be also odd:

[ERROR] (/Users/nantas/jenkins/workspace/Creator_2D/cocos2d-x-lite/mac/cocos2d-x-lite/cocos/scripting/js-bindings/jswrapper/v8/Object.cpp, 574): Invoking function (0x7ffa8d53e730) failed!

“nantas” is not a user on my system.

@fabianhemmert can you provide a zip file of your project please. Engineering will take a look.

Sure, thanks for looking into this!

(I’d prefer to PM or email you the download link, as the project contains some private data - can I do that?)

Sure. However you wish to send is fine. I’ll get it over to the team to review.

Perfect. Where should I email it to? :slight_smile:


Thanks! I’ll be in touch soon!

And here’s a big thank you to the Cocos Creator engineering team! You fixed my project’s update issues – thank you very, very much! Great support! Keep it up! :slight_smile:

Just reviewing the game.js file that engineering re-worked into working on 2.4.2 (which I am very thankful for!) – I just noticed that some parts have been commented out, namely those invoking SDKBox:

    // CocosCretor 2.4.0 not suport sdkbox

    // if (cc.sys.isMobile) {
    //     sdkbox.IAP.setDebug(true);
    //     sdkbox.PluginReview.init();

Is there any workaround? (I’m sure there is?)
Or should I simply follow the integration guide for SDKbox’s IAP and Review again? (Were they upgraded? Or is there, as engineering’s comment suggests, really no support? I’m a bit confused - thanks for clarifying!)

CocosCreator 2.4.0+ will not builtin sdkbox.

but you can download sdkbox from CocosCreator store. http://store.cocos.com/#/resources/detail/1880
or install sdkbox by self. http://docs.sdkbox.com/en/qa/install_sdkbox/

I see, thanks for the clarification! It works now.