Have an old project made in Cocos Studio 1.3.0 - can't find a way to open it

Hello, as the title says I have an old (2014-15ish) project that was originally created in Cocos Studio 1.3, however I can’t find a download link to any version of Cocos Studio to open it.

I have installed Cocos Creator, and the dashboard tells me the project needs version 1.0.0 of Cocos Creator to open, which I also cannot find a download for. As a last resort, I migrated the project to Cocos Creator 3.5 (after saving a backup) - the migration apparently “worked”, but when I open the project I’m greeted with only the default new project scene and assets.

This project is over 100k lines of code, so it isn’t an option to simply remake it, and I really would like to be able to work on it again. Any help finding an old version of Cocos Studio or successfully using Cocos Creator would be appericiated, thanks.

Maybe this will help you:

I’ve tried every Cocos Studio link in that list and none of them have working downloads. In general it seems that only about half of these links work, and the half that do are mostly the newer ones that are available to download elsewhere :frowning:

http://cdn.cocos2d-x.org/CocosStudio_v1.6.0.0.exe
try this?

1 Like

EDIT: Link works when opened with Firefox, thank you! I’m currently working but I’ll see if this can open the project successfully later today


I just see a blank page when I click this, do I need something other than the Cocos Dashboard to open it?

Looks like almost all of the links in on that github page work in firefox, but not chrome. Strange. Thanks for the help @Koei !

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.