Creator frozen in "Importing Assets"

It happened after some modification in a sub-project, then this project was copied into the main project.

There is any way of know what is causing this freeze? The menu bar works, but the engine never loads.

The engine console

How do you import assets?

Coping all files and folders inside assets, except resources folder (we make sure that nothing is pointing there), including metas.

For yesterday hitting Ctrl + R solved the problem, but this is something that other coworkers are facing, so if we know what we shouldn’t do would be great.

You should need to close the editor, then copy it to the project file, open the editor and re-import it.

That’s kinda what I do actually. This process is made with the editor closed.

(With the editor closed - automated script)

  • Delete the internal libraries folder content (is a bundle, so the meta of the folder is not touched)
  • Delete the mini games folder content (is a bundle, so the meta of the folder is not touched)
  • Copy the used libraries inside the internal libraries folder
  • Copy the mini games assets folder content, except resources, into it’s respective folder
  • When it’s done, open the project with CC.

This usually work, but sometimes the creator is freezing in the “Importing assets” screen

What is the version of your editor?

Is there a asset parsing failure causing this? You can use the terminal to open the editor to see if there is an error log.

2.4.1, no terminal error. I tried this just after I posted here.

Don’t know if those infos should help, but my project is very big (~10GB), and Creator usually stops responding when is actually importing assets, you can’t use the menu bars or move the window, but when this occurs, it responds normally, so the menu bars work and you can move/resize the window as much as you want. For me looks like some error occurred, but was suppressed.

More things that I did and still didn’t work:

  • Delete library, temp and local
  • Change the project.json version back to 2.3.3 (I’m porting the project from 1.9.3, passing through 2.3.3 because it still have the warnings)

What I did that did work:

  • Hit Ctrl + R when the window start responding again.

This is more difficult to troubleshoot, because no error is reported, which means that the resource import is normal。

it’s possible that the message is not returned after the resource import is complete.

Are you stuck in the resource loading screen?

For example:

yeah, that’s the screen.