Compile cpp-tests ->? Compile error Cannot open libcurl_imp.lib :(

Compile cpp-tests ->? Compile error Cannot open libcurl_imp.lib :(
0.0 0

#1

Any Idea what that is ? Anyone ?


#2

platform? version?


#3

Windows 10, brand new download from coco2 site, so newest version


#4

I did compile the win32 folder !


#5

I also encountered the same problem.
I am using VS2013 and building the cpp-tests.
I got: error LNK1104: cannot open file ‘libcurl_imp.lib’

Any solution?


#6

We have to wait for the Cocos2dX God to show mercy on our souls - @slackmoehrle


#7

I’d suggest running download-deps.py and trying again.


#8

A yes I remember when i first installed Cocos2d-x I had to install python. Since I formatted my PC i had forgot about that installation process and just used my git project . Ill install Python now and check it out


#9

Same problem here. Cocos2d-x-3.14.1, Windows 10, Visual Studio 2015, Python 2.7.13
I ran download-deps.py and got “Not need to update!” response. Not sure how to fix.


#10

I can test this. I was planning on getting a surface book this week. I’ll try in a virtual machine tomorrow


#11

Thank you, FYI, I’m able to create a new project that works and builds in Visual Studio 2015 (using “cocos new -l cpp proj_name -d dir_name”).

Haven’t been able to get cpp-tests working though.


#12

solution,
A) Enter the folder “C: \ cocos2d-x \ cocos2d-x-3.14.1 \ build”
B) cocos2d-win32.sln open with visual studio 2015

Recompile in order: click on each project recompile only the chosen project:

  1. libbox2d
  2. libbullet
  3. librecast
  4. libSpine
  5. libcocos2d
  6. libluacocos2d
  7. libjscocos2d

C) can complete the tests

Lua-tests
or
Js-tests
or
Cpp-tests


#14

same error on windows 10


#15

I’ve attached the lib I used, I just took it from my v3.10 build into my v3.16 build. seems to work but I also ran into the issue where download-deps.py built everything but that lib.

FWIW python download-deps.py -f redownloads everything even if you’ve got it.

libcurl_imp.zip (13.6 KB)

It’s not a zip, just rename to lib