Cocos2d-x v3.14 released!

Cocos2d-x v3.14 released!
0

#21

hmm, I don’t know off hand. cocos run --help didn’t seem to yield any help here. I usually just open XCode and run/debug from there.


#22

I tried to build tests for android, but I get this error. I have not had this problem with 3.13.1. What’s the matter? How to specify directory for NDK_MODULE_PATH?

D:\_______cocos2d-x-3.14\tests\cpp-empty-test>cocos run -p android -j 10
Building mode: debug
Using Eclipse project : D:\_______cocos2d-x-3.14\tests\cpp-empty-test\proj.android
running: '"C:\Users\Zver\AppData\Local\Android\Sdk\tools\android" update project -t android-13 -p D:\_______cocos2d-x-3.14\tests\cpp-empty-test\proj.android'

Updated project.properties
Updated local.properties
Updated file D:\_______cocos2d-x-3.14\tests\cpp-empty-test\proj.android\proguard-project.txt
running: '"C:\Users\Zver\AppData\Local\Android\Sdk\tools\android" update lib-project -p D:\_______cocos2d-x-3.14\cocos\platform\android\java -t android-13'

Updated project.properties
Updated local.properties
Updated file D:\_______cocos2d-x-3.14\cocos\platform\android\java\proguard-project.txt
Building native...
NDK build mode: debug
running: '"C:\ndk\ndk-build" -C D:\_______cocos2d-x-3.14\tests\cpp-empty-test\proj.android -j10 NDK_MODULE_PATH=D:\_______cocos2d-x-3.14;D:\_______cocos2d-x-3.14\cocos;D:\_______cocos2d-x-3.14\external NDK_TOOLCHAIN_VERSION=4.9 NDK_DEBUG=1'

Android NDK: WARNING: APP_PLATFORM android-13 is larger than android:minSdkVersion 10 in ./AndroidManifest.xml
Android NDK: WARNING: Ignoring unknown import directory: D:\_______cocos2d-x-3.14
Android NDK: D:\_______cocos2d-x-3.14\cocos/ui/Android.mk: Cannot find module with tag 'extensions' in import path
Android NDK: Are you sure your NDK_MODULE_PATH variable is properly defined ?
Android NDK: The following directories were searched:
Android NDK:
make: Entering directory `D:/_______cocos2d-x-3.14/tests/cpp-empty-test/proj.android'
D:\_______cocos2d-x-3.14\cocos/./Android.mk:327: *** Android NDK: Aborting.    .  Stop.
make: Leaving directory `D:/_______cocos2d-x-3.14/tests/cpp-empty-test/proj.android'
Error running command, return code: 2.
D:\_______cocos2d-x-3.14\tests\cpp-empty-test>

#23

What is your command?


#24

I hope it will be developed in another way, not as all tools before, because tools like “cocos” was bad(wanna put another word here), cocos studio bad too an so on. And also open source, right?


#25

To early for me to know. But we will ask everyone for feedback about what this tool needs. Ricardo will be working on it soon once he finishes c++ support for Creator.


#26

So, now if I want to use prebuilt libs I should create project as usually with souce code, then remove cocos2d project and folder from it, and fix paths for cocos2d, that located in another folder(like /Data/CocosX/…) and with already genereted libs?

Currently I did this and saved build time and also indexing time in Xcode. Without prebuilt libs it’s so slow…


#27

We are working on this.


#28

Where i can find fullscreen and resize method ?


#29

It’s in cocos2d-x/cocos/platform/desktop/CCGLViewImpl-desktop.h and cpp


#30

HI
few days back i tried to use android studio project with cocos2d-x v3.12. Projects runs from Terminal but when i open project in android studio Gradle build Failed and i couldn’t resolve it. Tried finding help but couldn’t get any. Does 3.14 (Pi) resolves it?


#31

What is the recommended Android NDK for this version ?


#32

After update to 3.14, my game has a problem with asset, some transparent image will be rendered error (like using wrong blend function). Even though other image of the same texture atlas is normal. Texture format is PVRTC4, platform is IOS.
Have switched back to 3.13.1.


#33

@OscarLeif

I’d like to know this as well, but just as a test I’ve gotten my game compiled with 13b (the latest) as well as clang!


#34

I use NDK r13b and it works fine.


#35

will it support cocos creator in c++ version? If yes then which version of creator support?


#36

How can i use disable multitouch option any docs…??


#37

RootView-Controller


#38

#39

a great job dear, congratulation regard FusionKraft


#40

The windows version cannot be extracted

http://www.cocos2d-x.org/filedown/cocos2d-x-3.14.1.zip