Cocos Dashboard v2.0.1 can't install Editor

Hello, cocos team!
Install Editor + button doesn’t work.
Creator 3.7.3 was installed by Cocos Dashboard v1.3.2.
The old dashboard works well when add or remove editor.
v2.0.1 can’t install Editor.

But it looks like you already install an editor, you cannot install version 3.8 ?
Is you click that button this should appear.

All of +Install buttons don’t work.
Is there url of each creator installer version?
ex. cocos creator 3.8.0.exe

If yes, I download it and locate it manually.

you can download from Github the source code and compile it.

But in other forum post they put the download link.


Does this problem still exist? If it still exists, please open CocosDashboard through CMD tool and try to create a new project. If you find an error message, please screenshot to tell us.

Thank you, OscarLeif.
How did you get the links of editors?

I run Command Prompt by Administrator, then run CocosDashboard.exe.
It doesn’t show Install Editor button.

Have you tried reinstalling Cocos Dashboard? We can see if we can work it out. The above error is the network request timeout, we have no clue.

Yeah, I tried reinstalling.
2.0.1 's +Install button doesn’t work, while 1.3.2 works.

Try using the shortcut Ctrl + Shift + i to open the editor console to see if there is an error message.

It shows some errors but it can install editor now.
I don’t know the reason.

Can you still download normally after closing the editor console?

Yes, I can.