Cocos Creator v1.1.1 released!

Cocos Creator v1.1.1 released!


Have you followed the steps told by @almax27?
It’s the common thing we all do while installing applications from external source which comes through different channel other than Apple’s… Your application already has certificate so it doesn’t need to come through app store or Apple’s channel! May be your application doesn’t have distribution certification, so it might not install on other’s mac…

You didn’t miss anything… It’s just that you didn’t follow the steps, told to u by almax which are common for all macs… and it’s one time.


Yes, I know how to run application downloaded from Anywere.
My current settings is:
Allow apps downloaded from:

  • Mac App Store and identified developers.

This means that OS X will run any application singed by identified developer.

Cocos Creator is signed by “Developer ID Application: CocoaChina (U7E7529TA5)”. This signature is valid.

My question is why OS X did not allow me to run it? That is what is absolutely not clear for me.


As the error states “the identity of the developer cannot be confirmed”. Your app works because (I assume) your machine generated the certificate, and therefore the developer can be confirmed… You.


Usually when I run unsigned app, OS X immediately shows the error telling to move the app to trash.
When I run CocosCreator, OS X opens small dialog with title "Verifying ‘CocosCreator’ ". And it shows the error in some seconds.
CocosCreator is signed by version 2. The signature contains a hash of all files inside .app. I may guess that any file was added into after it was signed. Just a guess.



I finally found the reason. It is “Electron Framework.framework” and probably “Mantle.framework”.
I used the command: codesign -vvv --deep --strict
" invalid destination for symbolic link in bundle
In subcomponent: /Applications/ Framework.framework
file modified: /Applications/ Framework.framework/Versions/Current/Libraries/Libraries
Unfortunately I do not know what to do with it. Maybe somebody can tell CocosCreator’s developers to know.



hello everyone,

so I developed this game in cocos creator and using java script. but I am having lots of fps drops in between the game play. I have developed few more games using same framework and i m have same problem

can anyone help me with this :frowning:


Hi tsundrud,
Did you find a solution for your problem? I am having the same issue here, the stars do not show.
Best regards


Sprite Filter Mode - Point doesn’t work. Version 1.1.1. This is very necessary for pixel art.

Best regards


Got an error while importing CocosStudio project.
If there was an option to send bug report directly to CC developers I would prefer it.

TypeError: r is not a function    at C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\app.asar\editor\builtin\project-importer\core\studio\csd-importer.js:1:20915
    at null.<anonymous> (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\platform\CCAssetLibrary.js:197:17)
    at loadedCheck (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\CCLoader.js:192:38)
    at CallbacksInvoker.invokeAndRemove (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\platform\callbacks-invoker.js:289:21)
    at JS.mixin.flowOut (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\pipeline.js:437:15)
    at C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\pipeline.js:71:35
    at C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\loader.js:240:29
    at loadDepends (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\uuid-loader.js:111:9)
    at loadUuid (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\uuid-loader.js:160:5)
    at JS.mixin.handle (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\engine\cocos2d\core\load-pipeline\loader.js:235:18)
    at EventEmitter.e (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\app.asar\editor\builtin\project-importer\main.js:1:204)
    at EventEmitter.g (events.js:260:16)
    at emitTwo (events.js:87:13)
    at EventEmitter.emit (events.js:172:7)
    at EventEmitter.<anonymous> (C:\Users\user\AppData\Local\CocosCreator\app-1.1.1\resources\atom.asar\browser\api\web-contents.js:134:25)
    at emitTwo (events.js:87:13)
    at EventEmitter.emit (events.js:172:7)


Cocos creator is awesome, very easy if you have experience is Unity, but I would like to use Lua, this could be real in the next releases?


Will the movable canvas(camera) in the future? So that the camera could follow the object.
Best regards


hi can anyone make a auto-complete for like in Vs Code?


It would be nice if you add a texture item/sprite that already exists in the project and it gets replaced.

Whenever I want to update a sprite I need to delete the png texture first and then add the new one. Is there a better way to do this that I don’t know about?


I got the same error TypeError: r is not a function when importing a project from Cocos Studio…
Where is the best place to submit a bug report ?


I tracked down the problem with the CocosStudio importer : it fails to import buttons with a custom font. And reseting the font in Cocos Studio is not enough, I had to manually remove the FontResource node from the .csd file.

Cocos Creator v1.1.2 released!


Was this ever resolved?