Cocos Creator v1.1.1 released!

Cocos Creator v1.1.1 released!


Just updated and the KEYBOARD event listener (which was working just this morning before I updated) is not firing anymore. It seems the update broke it. Any idea what might be going on?


YES!!! You added Collider Component System, thank you so much for that!
I have been waiting for that to finish developing my mobile game!

Thanks Cocos Team, you guys did a really good job with this update!


currently with Cocos Creator 1.1.0, i can’t build on Android-studio

Ne-On:jsb-default raksa$ cocos compile -p android -m debug --android-studio
Building mode: debug
Using Android Studio project : /Users/raksa/Desktop/projects/cocos-creator/NewProjectFromExample/build/jsb-default/frameworks/runtime-src/
/Users/raksa/Desktop/projects/cocos-creator/NewProjectFromExample/build/jsb-default/frameworks/runtime-src/ is not found


Where can I find option to import project from cocos studio? I cannot find it. What’s ETA for c++ support?


Hi @slackmoehrle
Not sure if busy these days but plz look this post:


Just updated today, and touch stopped working in browser preview both on desktop and mobile. I guess the canvas or its parent wrapper my catch focus…

UPDATE: it turned out that my cc.EventListener instance is paused by default, and it is not “unpaused” anywhere. Moreover there is no “public” method to unpause it, so i ended up calling _setPaused(false) private API in my code…

@slackmoehrle I would suggest to add this change in behaviour to breaking changes list

While reading the source code of the engine i found that comments in cc.EventListener may be wrong

`EventDispatcher::resumeAllEventListenersForTarget(node)` will set the paused state to `true`,
while `EventDispatcher::pauseAllEventListenersForTarget(node)` will set it to `false`.

link to github


I am just starting to learn Cocos Creator and am working through the tutorial at this link:
I was able to get the prefab stars to appear in version 1.0.3 but following the upgrade they no longer display.
I tried erasing the entire demo project and starting over, but the stars still don’t appear. I have made it to the end of the “Generate stars at a random position” section where it says “After saving the script, click the preview button. Then in the browser you will see that a star is dynamically generated after the game is started!”
What do I need to adjust to use the star prefab?


Where can I find option to import project from cocos studio?


Any planes to implement the bones animation editor into cocos creator ?


Does it support MacOS 10.10.5 ?
I downloaded, opened .dmg, dragged CocosStudio to Applications and ran. It shows the error:
“CocosCreator” is damaged and can’t be opened. You should move it to the Trash.



You should update to 10.11.5.

Because it already can’t work 10.11.2 version.


I don’t have access to a 10.10 machine to test this, but I will ask the engineering team about os requirements.


It worked on 10.10.4
So, no worries…
As I said earlier also… Just remove the old creator and download and install a fresh one only after removing the previous one. May be this can solve this issue.


I have never installed CocosCreator before. I have only installed Cocos and CocosStudio 2.
I planned to upgrade my Mac OS before, so I decided to do it today.


Could someone tell me how Cocos Creator compares to SpriteBuilder? I’m very new to game development, and I was using a Make School tutorial on how to build a Flappy Bird clone with SpriteBuilder and Cocos2d/Swift to try to get a feel for it. But then I realized that SpriteBuilder seems to be dead (no updates in forever, and is not in the App Store anymore), so I don’t want to continue down that road if it’s a dead end. Creator looks like it might be the same kind of thing, but I can’t find any information (other than the sparse bit on this site).

Also, if Creator is a SpriteBuilder replacement/improvement, are there any similar tutorials that teach how to use it while making a game, like the Make School one? I saw the links to the sample games, and one of them is a Flappy Bird clone, but I don’t see any materials to go with it. I tried just downloading it and opening it in Creator, but when I try to run it, it opens a browser window that says there isn’t anything in the scene and asks me to add something.


Go with spritebuilder if you can code in ObjC or swift AND don’t want to wait for cocos creator to get mature.
Personally, cocos creator is right now at a point of playground where you can experiment with features that are rolling out now with time and can make only very few types of games and you would have to do everything with the code for the features that are not provided through creator’s GUI.

For Spritebuilder, it’s old and features for building almost all (2D) games are already there.



I upgraded my iMac to 10.11.5, downloaded CocosCreator_v1.1.0_20160531.dmg, opened it, ran CocosCreator and got the error after during OS X verification process:
“CocosCreator” can’t be opened because the identity of the developer cannot be confirmed.
Your security preferences allow installation of only apps from the Mac App Store and identified developers.

What I did wrong?




Nothing, this is an Apple security measure to help prevent malicious software being installed. Cocos Creator isn’t Malicious, don’t worry :stuck_out_tongue: it’s just not in Apple’s database.


  1. Open OS X System Preferences > Security & Privacy
  2. On the “General” tab click the lock in the lower left corner to unlock the general preference pane
  3. Under “Allow applications downloaded from:”, select the “Anywhere” radio button

Be sure to reset the setting to it’s previous setting after you have installed Cocos Creator.



Yeah… by default Mac doesn’t allow the application to be installed which are not listed in Apple’s DB(actually the ones which are not installed through appstore or itunes). So, follow the steps told by @almax27

That would help.



I have an OS X application that I sign with my certificate and I distribute it from my site. I do not upload it to AppStore. I have just downloaded it from my site, ran it and OS X tells nothing.

I checked the signature for CocosCreator: codesign -dvvv /Applications/
Authority=Developer ID Application: CocoaChina (U7E7529TA5)

It is valid.
It is not clear why my signed application can be started, but signed CocosCreate cannot.

Why I got the error? Maybe I miss something?