[Cocos Creator 3.8.1] Cocos Editor not working properly on Windows platform when "Use native engine for scene editor" is selected in project preferences

native.fileUtils is not available when using preview in editor option for running the game. To use native.fileUtils in preview in editor mode, I’ve turned on the “Use native engine for scene editor” from File → Preferences → Laboratory → Scene → Use native engine for scene editor.

Now the native.fileUtils can be used in preview in editor mode but now its breaking the cocos editor, random game scene is rendering on top of the editor. This is happening on windows platform only but working fine on mac os.

  1. Use native engine for scene editor is selected and editor is reloaded now random scene view can be seen here on top of the preferences window and in the hierarchy panel.

  1. Editor when scene is not running

  1. Editor when scene is running

Cocos team please look into this issue for windows platform. I’m Looking forward for this fix in the future versions of cocos creator.



Hey, @zhangxm @mr.kylin please have look into the issue mentioned above. I’ve turned on the Use native engine for scene editor because I want to use native.fileUtils with Preview in editor mode but doing so I’m getting issues with the editor not working properly.

As i know this feature is an experiment feature. I just synced the issue to my colleague.

1 Like

Thank you for the response. Yes it is an experimental feature but it’s working fine on mac os and only breaking the editor on windows os. I just wanted to report this issue so It can be fixed in future version of Cocos Creator. Being able to use native.fileUtils with Preview in editor mode will be very helpful for the project I’m working on. Looking forward for the fix in the future version.


1 Like

Any other way to access local or server files?