Can't run apk Cocos Creator 1.7

Can't run apk Cocos Creator 1.7
0.0 0

#1

I created a project with cocos creator 1.6, it worked then update to 1.7

After installing, app stuck at:

E/cocos2d-x: JS Exception: scriptEngineType is not defined, file: assets/src/jsb_polyfill.js, line no: 58

I tried to remove scriptEngineType but go stuck at scheduler.scheduleUpdate, file: assets/src/jsb_polyfill.js

Android Studio, NDK 13b

Any solution? Please help :frowning:


#2

Let me ask our engineering team to have a look.


#3

Did you customized the engine?


#4

Nope, I just press build with the android platform in editor window then open with android studio and run Project.


#5

Do you have the project that you can compress and get to us?


#6

Did you delete build folder and re-build your project?
It seems that you’re using wrong cocos2d-x-lite engine.


#7

Yup, I tried but failed.


#8

Thank for your attention!

I solved it by creating a new project with cocos creator 1.7, then copy asset to.

But now I meet a new problem when run my app:

Tried return at the first code line of the start scene but still failed…


#9

The same with creating a new project then build it.


#10

Re-install cocos creator 1.7 -> create a new hello world project -> build -> compile -> open apk -> crash :frowning:

Anyone had solution? Please help!


#11

Is there any crash stack before this line was printed?


#12

I found it can’t work on an emulator. On real device it’s ok.
Thank for your attention.