C++ and Lua support for creator alpha0 released

C++ and Lua support for creator alpha0 released
0.0 0


I’ve downloaded your plugin from github, opened it in cocos creator and selected my old cocos2d-x project as a target project. This lead to create config.json inside it.


The plugin will not create config.json. You can remove CreatorReaderBinding.cpp/h to fix it manually, i think i have to use other way to check project type.


@piotrros could you please share your folder structure of your cocos2d-x project? Thanks.



This is how it looks. Frameworks, res and config.json were created after building in Cocos Creator (Project -> LuaCpp Support -> Build Now).

As I said I’ve removed binding files and it builds, but crashes when trying to run with demo scene (as screenshot above states).


I think the reason is why there is config.json. Plugin will not generate this file. You can remote this json file to check if the plugin will generate it again.


Removing config.json worked! Now it thinks that it’s c++, because it creates files in the right places. I had to manually add references to reader and creator in xcode and also fix this line:

CreatorReader.cpp, line 804:




as xcode advised me to do.

And… it finally worked! Yay!


So i have to change other way to check project type.

Any difference?


Oh, it seems remove t. But i don’t have problem, what’s your engine version?


It’s 3.14.1 as I said. It’s a typo, maybe it was fixed 3.15, who knows :slight_smile:


Oh, i think i know the reason. Because you uses prebuilt version, so it contains config.json. About sprite->setStretchEnabled, i don’t want to change it, since current method name is correct. May be it is fixed in v3.15.


config.json is from cocos studio I think, because I have this file in all projects :smiley:


@piotrros i use other way to check project type: https://github.com/cocos2d/creator_to_cocos2dx/pull/87.