App open and close after integrating Admob

App open and close after integrating Admob
0.0 0


Hello, i followed everything on admob cocos creator.
when i build, compile and run on device, my app just goes to a black screen for 2 secs and close. Can i know what may be the problem please, this is frustrating me days now.

Thanks in advance


@nite i run my app on a device, i dont have any logs, the app builds, i then compile and press run, when it opens on the phone it opens and closes with a black screen. the app worked perfect before i tried to integrate admob


@yinjimmy can help with this.


why do not have any logs? Could you plz show the logcat by ?


and which creator version did you integrate?


im using version v1.6.1.

ok so i added some lines to Cocos2dxActivity that i saw were missing. Now i got the app to run. but no ads are showing.

when i run pidcat i get a huge amount of process when the phone is connected. the same goes for android studio.


With android studio, you can choose only show the logs of your app, can you send us the logs and we can help diagnose what went wrong.


ok i got it to work, after i added the stuff to Cocos2dxActivity, i then had to add line in my manifest file. now it works