3D particle not showing up in Cocos 3.8.1

Hello folks, I am creating a casual mobile game in which user have to join some boxes. and when certain conditions are met, then those boxes will blast.

For showing the blast effect, I am using 3D particles.

In android device, when a lot of boxes blast at one time, then the particles are not visible but If I add some delay between consecutive box blast, (suppose 100 milliseconds), then the particles are visible.

If I run the game in cocos editor preview, then particles are always visible.

Any suggestions what could be the potential reason?
Thanks in Advance.

Could you provide the code related to box blasting so that the problem can be analyzed

Here is the code for box blasting.

for(const box of blastableBox) {
box.getComponent(ParticleSystem).enabled = true;

blastableBox is the array of boxes which we are instantiating before running this loop.
I have also tried creating a pool of box particles and instead of instantiating at the time of blast, I filled that pool with box particles at the start of the game. But still, particles were not coming.

this issue happens with everything else in the engine too. The behavior is if you just enable something like UI, physics, particle system, it seems to need some time before it can be used. So it will not run in the same frame that it was just enabled.