WebGL error 1282 - Issue after updating cocos2d to 2.1.2

WebGL error 1282 - Issue after updating cocos2d to 2.1.2
0.0 0


Hello there,

I’m facing some issue after updating to the new version of cocos.

Using firefox, my Scene is perfect. If I use google chrome (it supports webgl), I see the following error in the console:

>> WebGL error 1282 CCCommon.js:125
>> WebGL: INVALID_OPERATION: vertexAttribPointer: no bound ARRAY_BUFFER

The result is that my Sprites are not showing up, also the colours of the lines I draw with cc.drawingUtil.drawLine are white independently of the colour I had set.

Any clue of what could be, or where I can start debugging?

Thank you,


^ Anyone experienced this issue? I can’t run my game in google chrome, because my sprites are just white rectangles….


All my .pngs are white, I’ve just tried with jpgs and it works…
Somehow the pngs are not working good, also the ccDrawingLine is white.


For now solved using this solution : http://www.cocos2d-x.org/boards/19/topics/25480

More specifically doing tempContext = null; in platform/miniFramework.js line 65.