undefined reference to `gzopen64'

undefined reference to `gzopen64'
0.0 0


I’m getting this error while compiling the tests on PCLinuxOS (ok, I know, cocos2d-x is for ubuntu).
I read somewhere on the internet that gzopen64 is included only in some modified versions of zlib, such as the one ubuntu uses.

Hope it’ll be solved,
Thank you very much guys,

I resolved downloading the source of the ubuntu version of zlib from [[https://launchpad.net/ubuntu/+source/zlib/1:]]. I compiled it and copied the *.so files to the cocos2d lib directory.

Now I get another error, when trying to run the tests:

./cocos2dx-test: error while loading shared libraries: libglfw.so: cannot open shared object file: No such file or directory

locate glfw

only gives the path to the libglfw.a file. I modified the cocos2dx Makefile to statically link it to the libcocos2d (the hack way, adding $(locate libglfw.a) in the static libs).
Now I get errors about X-related functions missing while linking the tests.

Probably with my 2nd “workaround” I introduced even more problem. Btw, the libglfw.so problem is related to cocos2d-x or my specific distro? Because I could fill a bug report to PCLinuxOs in case…

putting lGL in the tests Makefile results in finishing the compiling part, but when I run the tests the linker gives an error:
./cocos2dx-test: symbol lookup error: …/…/lib/linux/Debug/libcocos2d.so: undefined symbol: XF86VidModeQueryExtension
lXxf86vm in tests Makefile and it runs… Now all I see is the red X on a black screen, but at least it runs :stuck_out_tongue: