[STEPS] ISSUE Compiling Cocos2d-x 2.0.4 for Android using Linux

[STEPS] ISSUE Compiling Cocos2d-x 2.0.4 for Android using Linux
0.0 0



I’m trying to execute Hello World using new library version 2.0.4 using Linux.

1º I change paths on $PATHCocos2d-x.2.0.4/create-android-project.sh [OK]
2º I change paths and compile Hello World’s code using $PATHCocos2d-x.2.0.4/TEST204/build-native.sh [OK]
3º I add to eclipse project [OK]
4º I add $PATHCocos2d-x.2.0.4/cocos2dx/platform/android/java [OK]
5º I add to Hello World propierties JAVA library [OK]

If i run the APP, it fail, because it don’t find the native library. I was thinking and… yes, cocos2d-x library it has not compiled like olders version using build-native.sh.

Where and How I have to compile it?

I have tried to compile using $PATHCocos2d-x.2.0.4//make-all-linux-project.sh but if fails because:

/usr/bin/ld: cannot find lGLEW
Then I have look for where I installed that library:
locate GLEW
I get:
And using:

I get same error.


I think you have misunderstood something, make-all-linux-project.sh is for building project for linux port rather than android port.
So if you want to build HelloCpp for android on linux system, you should goto HelloCpp/proj.android , and execute ./build_native.sh.


Yes, it was my fault, the name path change from my old version to the new one. Now Cocos2d-x is compiling.

Thanks you very much.