Running TestCoscos2dx project on PlayBook NDK 2.0 Beta

Running TestCoscos2dx project on PlayBook NDK 2.0 Beta
0.0 0



Is it tested on PlayBook NDK 2.0 Beta?
I have installed PlayBook NDK 2.0 Beta successfully, and tested embedded samples of PlayBook NDK 2.0 Beta successfully.

But , I failed to run TestCoscos2dx project on it.

At first , I ran into problem of not finding “so” files including “”,“” and “”, it can be resolved by editing the bar-descriptor.xml file.
After that, I built it successfully and tried to test it on PlayBook with development mode enabled, but I got the following error:
unknown symbol: accelerometer_read_forces
unknown symbol: accelerometer_set_update_frequency
ldd:FATAL: Could not resolve all symbols

anything I missed?


Hi, we just tested playbook port on ndk 1.0 release. Using 1.0 to have a try.:slight_smile:



Many thanks for your quick reply.
I tried to fix the problem after I posted this problem, and found that it can be resolved after I modified the bar-descriptor.xml file with right directory of the “so” files, instead of copying so files to the directory used in the bar-descriptor.xml files.

It works now, and it is excellent!