[Resolved]a bug width v2.2

[Resolved]a bug width v2.2
0.0 0


When I run the cocos2d-x html5 version 2.2 test cases, It caught a exception width info “Uncaught NotFoundError: An attempt was made to reference a Node in a context where it does not exist.” in platform/jsLoader.js, I fixed it by changed the code “new Image” to "document.createElement(‘img’).

bug.png (18.1 KB)


Thank you.
I will fix it soon.

Could you please tell me what type and version the browser is.

Best regards


browser Google Chrome 版本 29.0.1547.76 m,Thank you.


Hi Feng,

I have fixed this bug at https://github.com/cocos2d/cocos2d-html5/pull/1167.



I edit the code, but it still has problem

Uncaught TypeError: Type error CCTexture2D.js:504
cc.Texture2DWebGL.cc.Class.extend.handleLoadedTexture CCTexture2D.js:504
cc.Director.cc.Class.extend._createStatsLabelForWebGL CCDirector.js:1102
cc.Director.cc.Class.extend.setOpenGLView CCDirector.js:792
cc.Director.getInstance CCDirector.js:1254
cc.Application.extend.applicationDidFinishLaunching main.js:44
cc.Application.cc.Class.extend.run CCApplication.js:344
cc.AppController.cc.Class.extend.didFinishLaunchingWithOptions AppControl.js:40
cc.Application.extend.ctor main.js:35
(anonymous function) CCClass.js:133
Class CCClass.js:177
(anonymous function) main.js:64

chrome 29.0.1547.76 m


I fixed by changed the code “new Image” to "document.createElement(‘img’) in all project files.