EditBox problem in android 4.4.2

EditBox problem in android 4.4.2
0.0 0


I tried the TestCpp, ExtensionText, when entering editing modee in the EditBox, there is no way to return or confrim, the only option is to back and cancel the typing.

Screenshot attached

Screenshot_2014-03-14-16-06-04.png (147.4 KB)

How can we get text input while editBox is broken?

what cocos2d-x version did you use?


I am also facing this issue. I am on cocos2dx version 3.0alpha0. I tested on galaxy nexus with version 4.2.2.Any help regarding this???


I download the rc version to check if this issue was fixed, but still not working
Using nexus 5 android 4.4.2


editbox still broken in 3.1.1. Tried with emulator on Android 4.1.2 and same problem. Only fixed when device has hardware keyboard.

I suppose we are all supposed to be using ui::TextField now? Tried dropping the test code into my project and it goes hunting for “Helvetica” and “Thornburi”, which I found in the tests folder and copied over but still not working.

So that leaves me with only JNI calls to get user input. Which I haven’t used for ages and have forgotten how to do.


I think this is fixed in the version on GitHub: https://github.com/cocos2d/cocos2d-x/blob/v3/CHANGELOG


Thanks, rather than risk spending another half a day negotiating the nuances of updating Eclipse with my latest cocos2d-x library to something potentially less stable is there any fix for v3.2? Preferably a couple of source files maybe?


No that I know about. FWIW, I didn’t have any problems going from 3.2 to the latest from GitHUB but YMMV.


You don’t want to use Eclipse then. On paygo internet so not worth the risk for me. Going to have a bash at getting pop ups from java showing in cocos2d-x. The instructions are for admob and I know there have been major changes since v3.0 in that I think we’re currently extending android.app.Activity instead of android.app.NativeActivity so that could break a lot of these tutorials. A separate topic, as and when. Can’t be coding a keyboard for every language, Stephen Fry was on about there being 7,500 of them tonight :slight_smile:


perhaps the fix is to add to the Android manifest in the activity element, something like:



@slackmoehrle I downloaded the latest 41MB zip file from github. Seems a bit small, is the other 160 or so MB identical to 3.2 and I should just unzip it over that? Thanks.


I would unzip it to a new directory and run ./download-deps.py after. This will keep what you have and the new branch separate in case you have to go back. No substitute for good backups :smile:
If you need more help, let me know.


Thanks, what a pity the first thing ./download-deps.py did was attempt to connect the internet, and die.

My own keyboard’s okay but I don’t know how to shut off all touch events when I’m in the handler to stop repeatedly actioning keystrokes that leave it as discoulered as a works keyboard.


I think, this issue is only in xperia handsets not related with android version. A friend of mine had same issue in xperia L 4.2.2 android. It didnt occur in nexus 5 4.4.4 android.