Could the leader team add the libs of mips version for android so that cocos2d-x can support mips arch

Could the leader team add the libs of mips version for android so that cocos2d-x can support mips arch
0.0 0


Now the amount of android device with mips arch is increasing. And the cost to support mips version is not expensive,so I think the leader team can think better of it.


Any one who has the same problem can tell the solution.


Hi everyone,

Just like liuzhidejll, i definitely needs cocos2d-x compatible on mips builds.

I’m new to cocos2d-x and i’m trying to make it work on MIPS (Target Android API 17, from Win7).
So far, i could make cocos2d-x v3.10 cpp emptytest work on armeabi builds.

By looking at this article from ricardo :
I’ve deduced it was possible to make it work on MIPS, but i’m not sure what is the best way to achieve that as of today.
I’ve seen there is a mips branch for cocos2d-x on github, should i go with this one or v3.10 is now better ?
Is there any external dependencies builds for mips available somewhere? Or some hints to creat them ?

Thanks for any help.


So, we don’t provide official builds for MIPS, but, yes, I was able to compile and run cocos2d-x successfully on an Android + MIPS device (in particular the Creator CI-20).

What you have to do is to compile all the dependencies by yourself. You can to clone this repo:

and compile all the libraries for MIPS. I needed to make some changes, which are here, so probably you should use these two repo as your reference:

Unfortunately, my changes weren’t merged into v3 so v3.10 doesn’t have my MIPS changes. But I’ll happily apply them into v3 if you can send me PR with the needed changes for v3.10


I feel pretty dumb right now, because i was expecting to find .c and .h files in

But the single things i can find in there are… .mak files ? Am i missing something obvious ?
Thanks for your awesome reactivity :smile:


what you will find there are scripts that will download the 3rd party libs source code and compile it for you.

Take a look at the README:


Yes thanks, i totally missed that.
I’ll be back when Cygwin will be ready then.
Thx again


Allright, Cygwin installed.

I tried to complete android.ini to support --arch=mips with adding :

and changing cfg_build_machine=“x86_64-pc-windows”

First error was about ANDROID_NDK not defined, so i added it as C:\SDK\NDK and it kept me on a Cmake error (couldn’t parse \S). I ended this error by changing it to /cygdrive/c/sdk/ndk.

I retried just for zlib.
This time it looks like Gcc had no idea where to find limits.h.
I did find a limits.h in cygwin64/usr/include, but didn’t find the right way to tell Gcc to go there.
As a temporary fix, i copied all files from cygwin64/usr/include in my ${ANDROID_NDK}/toolchains/mipsel-linux-android-${cfg_default_gcc_version}/prebuilt/windows_x86_64/lib/gcc/mipsel-linux-android/4.9/include folder, without erasing already existing files.

Zlib.a seems to have compiled.

Now a just tried to make it for the others libs, without success.
All of them keeps in ending by logging : checking whether the C compiler works… no

It’s already a dense post, so i’ll wait your reactions before i dig deep in some absurd actions.


sorry, but I don’t know how to compile when using windows as a host machine. I never did that.

But I merged my “mips” changes in the “3rd-party-libs-src”:

I tried compiling libcurl (which has a lot of dependencies) and it compiled Ok for mips.