Cocostudio UI, animation and scene editor don't open

Cocostudio UI, animation and scene editor don't open
0.0 0


I’m using CocoStudio with no problem (on Windows 8 x64).
But I tried to install it on another computer (windows 7 x64), and the graphical editors don’t open. Game data editor opens up corretcly, so does CocoStudio.exe, but none of the visual editors work (UI, scene and animation editors). I tried to double click on their executables, with no success. The process appears for a few seconds on windows “task manager”, then it dissapears.
Is there any way I can do a test to see what is going on?

Of course, I installed .NET framework 4, Visual C++ 2010 and 2012, both x86 and x64 versions.

Thank you!


Maybe update your graphic card driver?


Sorry for thump up this thread
But i got the same issues now, I’ve try to update graphic card driver but nothing change.
I test bold version and but bold of them can’t work. Just data editor can open.

(Sorry for my bad English)


try it in windows 7 32bits, it works for me. But not in 64 bits.


So, not only is CocoStudio not available for OS X, it doesn’t work on 64 bit version of Windows?


Same thing here on windows 8.1 32bits :frowning:


Hi, I just downloaded and installed cocos 2d-is and 2d-x and studio today and all the files that support them, ie visual studio, .net, adk, ndk, ant, Python, etc and everything seems to be working except I am having the same problem posted here on win 7 32bit. Animation gives the render error and quits, uI and scene editor don’t do anything and the code editor works. I uninstalled, and reinstalled, and made sure my graphics card had the latest driver. Is there anything else I can try to get cocos animator, u i and scene editor to work. Thx. -Paul