Cocos2dx debug troubles in mac version Marmalade sdk.

Cocos2dx debug troubles in mac version Marmalade sdk.
0.0 0


I created simple project from helloword sample in Xcode 3 and I add some breakpoints in the main class.
If I build and run this in Simulator ( Debug | s3e_simulator_debug) then process run without stop in breakpoints. In gdb console displayed many messages: “ERROR: 5 in device 25”. What is means? and How to fix it?

Also I tried repeat all this with helloword sample without any changes in project code - this work fine, gdb stoped on first breakpoint and no error messages in console.
_(I used cocos2dx from git repository and last marmalade sdk)_

Maybe has way debugging cocos2dx applications in s3e_simulator_qemu?


I recreated xcode project with Mkb, breakpoints now work normally. I have no any idea about what’s wrong in old project.


Can you share the new mkb here? I would compare these 2 files to check if anything wrong in the old project.


Mkb files was same. Old xcode project was broken.

mkb - [[]]
old project - [[]]
new project - [[]]



issue #635 created


I too getting the same error “ERROR: 5 in device 25” .I’m using cocos2d-1.0.1-x-0.9.1


Hi Walzer Wang,
I posted about the message “ERROR: 5 in device 25” and the black-screen then comes on marmalade forums.
You can refer this page-

They said the cococs2-d might be trying to initialize the accelerometer. (I haven’t code for that, but cocos2d-x might be initializing internally.I really don’t know.)
and marmalde sdk osX simulator doesn’t support accelerometer. Thats the reason , you are getting error on mac version.

I tried my code on both xcode and visual c*+ 2010 express and this error comes only in xcode. Code run fine on visual c*+. May be marmalade guys got the correct reason for error?

Hope this info will be useful for you.


@Evgeniy Tokarev , refer Your problem can be solved.


This was solved in CCApplication_marmalade.cpp, revision c0a12bd6