Can't run binary in Debug.win32

Can't run binary in Debug.win32
0.0 0


Hi, everybody i’m beginner.
Now i can build and debug in visual studio succeed follower to [[]]. And i will try create new project on solution in cocos2d-win32.vc2010 named “myGame” and debug in visual studio to succeed too. but i can’t run the binary target myGame.win32.exe(in Debug.win32 folder) .which in visual studio i defined output Resource in Post-Build Event -> Command Line

xcopy /Y /E .\Resources\*.* $(OutDir)Resources 

but it not allow refer path from folder Resources to created, become to refer path old(D:2dx\Debug.win32).

how to change path from D:2dx\Debug.win32to D:2dx\Debug.win32\Resources ?

thank you for answer to coming soon.
P.S. i use cocos2d-x-0.13.0-beta to dev.


You can change the path like this:
right click project in vs > Properties> Debugging -> Working Directory


yes, i trying changed to path in Debuggin - > Working Directory






Which it can debug and run in visual studio. But program it can’t run due to directly still to same.


I just created a new project. I am trying to run the exe that is created in Debug.win32, but Im getting an error stating that “Get Data from file(CloseNormal.png) failed!”
I have tried setting the Working Directory in the properties tab of the project, but that does not help.



Having the same problem here.
Been trying to solve this all day without luck. I’ll keep trying.


I changed the working directory but the exe still wouldn’t run.
Only copying the asset files (without folders) under “Resources” to the Debug.win32 or Release.win32 folder actually worked. Both debug and release exes now work as expected.
Here the setup I am using:


This works only on the Dev machine. I sent it to a friend and give a long list of dll’s that were missing. Even after downloading the torrents fromt the internet, the exe does not start. I cant remember the exact error right now, but it does not run the exe for sure.