Can't "export" my test app to eclipse

Can't "export" my test app to eclipse
0.0 0


I know, this problem has been discussed a lot, and i’m very sorry about another topic about it. But… i’m stuck (actually, i tried a lot of ways to solve my problem and read a lot of solutions/topics) and can’t move any further. I don’t know anything about android/cocos2d/linux/ndk/eclipse/java and so on, so i even can’t understand what’s going wrong.

I tried this great step-by-step tutorial:

… and failed at step 11. Even if i can avoid infamous “NDK_ROOT error”, i’m getting a lot of errors because of “wrong” include directives.

Oh… dunno what to say, maybe it’s just me who’s such a dumb idiot. But i really, really need a good explanation, what to do.

My goal is to create an app in familiar MSVS/C*+ environment and export this “native pc” app to an android app. That’s all.
If it’s not possible then i’d like to know, how to create cocos2d-android.jar. I can study Java if there is no choice left :slight_smile:
Conditions: “clean” PC, Win7.64. MSVS2010* latest Android bundle (SDK+Eclipse), latest Android NDK, latest Cygwin and latest Cocos2D-x are installed.

Thanks in advance.