Build-win32.bat Error

Build-win32.bat Error
0.0 0


Please help! (I’m using Windows 8 btw.) I downloaded Cocos2d-x, put it in a folder called C:2dx and then try to run build-win32.bat. A window pops up and then I get the warning: “Can’t find the binary”TestCpp.exe“, is there build error?” I found a thread addressing this issue (seems to be a common one) but none of the advice there seemed to work for others.

So I opened “cocos2d-win32.vc2010.sln” in Visual Studio Express and clicked Build + Build Solution. It does that for about 5 minutes then gives me a list of warning and errors. I then click on Debug + Start Debugging and right away I get a warning, “Unable to start program ‘C:2dx\Debug.win32\libBox2d.lib.’” I hit ok and nothing else happens. The file exists (libBox2d.lib is where it supposed to be) so I don’t know what the deal is. Everything I try to do and it won’t start debugging, which is apparently the way to get win32.bat to work.

I’ve tried with “cocos2d-win32.vc2010.sln” and “cocos2d-win32.vc2012.sln” (not sure the difference). I re-downloaded cocos2d-x and tried again but I always get the “Can’t find the binary” warning when I try to run win32.bat.

Any help would be much appreciated!