Can't make Cocos2d-x compile on Ubuntu 18.04

Can't make Cocos2d-x compile on Ubuntu 18.04
0

#22

but the instructions don’t say to do this for 18.x :slight_smile:


#23

ok i downloaded again through git, repeated steps from documentation and i still get the same error (in this case i don’t run ./install-deps-linux.sh). I’m sure i run git submodule update --init, git submodule update, ./download-deps.py, download the dependency, and then build the makefile for linux-build as the documentation.


#24

Ok let me test on a clean Ubuntu 18.04 install.


#25

thank you. I try to install with zip from cocos website, build the make file as the step from documentation, and the build is complete (I still don’t know and wondering why). But when i try to run the binary cpp-tests it’s say the error like this.
Screenshot%20from%202018-10-11%2020-19-24


#26

According to this thread i’m finaly solve the problem.

But i still wondering why it’s failed to build when cloning from git repository.


#27

I’ll run through the instructions again just to be sure.


#28

I didn’t run into any issues, but in the sake of not leaving someone hanging I added the thread you referenced to the docs. This PR