Android NDK: jni/Android.mk: Cannot find module with tag ‘cocos’ in import path

Android NDK: jni/Android.mk: Cannot find module with tag ‘cocos’ in import path
0.0 0

#21

Yes, you are right, but as I said v3 has the same problem.

And 3.14 version is guaranteed has the problem of decoding audio on some devices. So it’s worth trying a newer version and hoping for the best.


#22

Many bugs are fixed in v3.15, and i haven’t synchronize v3.15 to v3.


#23

Hello @zhangxm

I’m trying to say that something is wrong with both of these branches. Please see the issue.

I also want to note that I reinstalled the OS and the problem is still here. So this is not a random error related to the environment or something.


#24

Please don’t use VS2010, it is not supported. Use VS2013 or VS2015.


#25

@zhangxm I’m confused again. I did not use VS2010. The previous screenshot from VS2017.
Probably I did not understand you correctly.

When you said that VS2010 is not supported, I thought that the Hello Word project is in 2010 format, and it does not support by VS2017.

This is a screenshot from VS2015. It took time to install it.

The branch v3.15.


#26

You can see your previous screenshot, it said (Visual Studio 2010) right of cc2dTest.

I’m curious how did you download v3.15 branch and run download-deps.py. Is there any error when running download-deps.py? Can you find external/Box2D/proj.win32/libbox2d.vcxproj?


#27

I do not know why this says (Visual Studio 2010), I opened the project in VS2017.

I run it, it downloads something, then unzip something, then it just closes.
I can not see if there are any errors. Or just do not know how.

C:\cocos2d-x-3.15\external contains only the config.json and nothing more.


#28

The new screenshot from 2017.

You can see the version in the About window.


#29

It is the issue. It doesn’t download anything. config.json is in cocos2d-x repo. Could you please paste the log that running download-deps.py?


#30
Microsoft Windows [Version 10.0.10586]
(c) 2015 Microsoft Corporation. All rights reserved.

C:\Windows\system32>C:\cocos2d-x-3.15\download-deps.py
=======================================================
==> Prepare to download external libraries!
==> version file doesn't exist
==> Ready to download 'v3-deps-130.zip' from 'https://github.com/cocos2d/cocos2d-x-3rd-party-libs-bin/archive/v3-deps-130.zip'
==> Start to download, please wait ...
==> Downloading finished!
==> Extracting files, please wait ...
==> Extraction done!
==> Cleaning cocos2d-x/external folder ...
'git' is not recognized as an internal or external command,
operable program or batch file.
Traceback (most recent call last):
  File "C:\cocos2d-x-3.15\download-deps.py", line 327, in <module>
    main()
  File "C:\cocos2d-x-3.15\download-deps.py", line 322, in main
    installer.run(workpath, external_path, opts.remove_downloaded, opts.force_update, opts.download_only)
  File "C:\cocos2d-x-3.15\download-deps.py", line 265, in run
    self.clean_external_folder()
  File "C:\cocos2d-x-3.15\download-deps.py", line 247, in clean_external_folder
    execute_command('git clean -fdx external')
  File "C:\cocos2d-x-3.15\download-deps.py", line 56, in execute_command
    raise Exception('Command ( %s ) failed!' % cmd)
Exception: Command ( git clean -fdx external ) failed!

C:\Windows\system32>

This log?


#31

The error message said git is not installed.


#32

So the new version wants me to have a git client or something? Why, oh why? I mean that 3.14.1 works fine without it.

I just go to the site https://github.com/cocos2d/cocos2d-x , then Clone or download, then Download ZIP,
then I download the cocos console similarly.
Then I unzip it, run download-deps.py and setup.py.

Am I so strange? :slight_smile: I do not use the git every day, so I never installed it.


#33

I installed a git for Windows, but it still does not work.


#34

No, you can not do it like this. It doesn’t include submodules. If you want to get codes from github, you should clone it and checkout v3.15 branch. If you want to get stable release version, you should get it from http://www.cocos2d-x.org/download.


#35

Ok, I’m pretty sure that you’re tired of this discussion already.

So I will ask only the last two questions.

Perhaps this is not the right way, but it worked with previous versions, since version 3.1. So now something has changed, and I’m not sure if it’s for the best. I’m not sure, but I think that I need only the cocos console from submodules, which I download manually.

  • Will you fix something in download-deps.py so that it will work as before?

  • When will the stable 3.15 be released?

Thank you again for your help.


#36

Ok, it is caused by this PR. It uses git to clean external folder. We should use other methods to do it. Currently, you can just uncomment execute_command('git clean -fdx external') to make it work.


#37

Thank you! :slight_smile:

Should I close this issue then?


#38

You are welcome. Yep, could you please close this one and create a new issue for download-deps.py?


#39

Done.


#40

@BPri thanks