Win32 deploy error

Win32 deploy error


I have cocos2d-x 3.17 im getting this error when i use the command deploy -p win32 -m release

Building mode: release
Required VS version : [2013, 2015, 2017]
running: ‘“C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\” “C:\Work\explottens\Explottens\proj.win32\Explottens.sln” /Build “Release” /Project “Explottens”’

‘C:\Program’ is not recognized as an internal or external command,
operable program or batch file.
Error running command, return code: 1.

Anyone got a solution?


I don’t use Windows often.

@dogwalker and @stevetranby do IIRC

It’s complaining about a path with a space in it. But I would think Everyone on Windows deploys to Program files/


note: I don’t have experience publishing outside of the new Windows Store, and only light exp. even for that.

Does it deploy there automatically (or rather by default?)
I’d recommend using an installer tool instead and just build to your working path build folder.
“C:\Work\explottens\Explottens\proj.win32\Debug" (or similar)

SPACES are the devil in paths. I get it (command separator), but still.

You can try prefixing all spaces with a backslash: ‘“C:\Program\ Files\ (x86)"

Beyond that you may have to tweak the deploy python script, which isn’t great, so I’d re-recommend building to a path without spaces and then using an installer tool (e.g. NSIS or similar) to package it up for release that eventually installs to prog files.


Thanks, I’ll try that!


were you able to find a good solution for this?


hey, Thanks for the help. the build is in the release folder but the size is 2.4gb … I tried NSIS but still the size is too big.

Do you know which script is ran for cocos deploy -p win32 -m release? It does seem to run cocos compile first which i ran manually like this
“C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\” “C:\Work\explottens\Explottens\proj.win32\Explottens.sln” /Build “Release” /Project “Explottens”
… but I cant find which script puts it in the bin folder as release and compact version.


This is what i needed

Thanks @stevetranby