V3.0 not reimporting fbx correctly after overwriting

Hello

Just found a situation yesterday, I had a model that had wrong Normals and then I asked the artist to fix it, after he did, I tried to overwrite the model in Cocos but nothing happens.

If I import the model with a new name, it works and shows with correct Normals. But if I try to import and overwrite to maintain all references the faces don’t update correctly.

Tried a lot of close/open/reimport and clear library but nothing worked.

This is a big issue because it means that I can’t update an existing fbx file, and every time that I need to, I will have to fix all the prefabs that may use that fbx.

Also tested with a simple blender cube with and without Normals flipped and had the same problem, overwriting the fbx file does not update the model in Cocos.

Can anyone help me with this?

I can ask an engineering team member to take a look at this topic.

1 Like

Sorry, can you provide these two models to facilitate our testing?

Here you go
Cubes.zip (7.1 KB)

Hello, it has been determined to be a bug,and I am very sorry for the inconvenience caused.
it will be fixed in version 3.1

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.