Unable to bake lightmap. (OSX 10.14.6 / CC3.0, CC3.01)

I can’t get for the life of me get any lightmap baking going.
I tried this a dozen times already and it always failed.

Wasn’t important at that time but now I do need it, so I would like
to know if anyone might have an idea why these errors get spit:

This happened since 3.0.0 preview. Still there in the latest version.
I followed everything always by the book and also tried some extra stuff.
No dice.

Thanks,
tL.

Looks like this is OSX only. Just tested the same with 3.0.1 on my Windows installation, seems to work fine there.

I will ask the engineering team to review this thread.

Hello, please refer to this document first to use the light map.
https://docs.cocos.com/creator/3.0/manual/en/concepts/scene/light/lightmap.html

Uhm. I did. But still: So why does it work for me on Windows for me 100% of the time and not on OSX (0% of the time)?
What difference does it make if I read the document?
I don’t understand…

Hello, I also tested it on OSX. Could you please upload your test demo to me?

Will do so when I am back / after the weekend. Thanks.

(However, this just never worked on any OSX project of mine, not a specifc one.
But I will pack a project anyways, there is some data in the LightFx folder, even after failure, maybe that helps…)

Clean small example project. The same setup works under windows, but
fails on my OSX machine here.
Screenshot from the error is inside the folder.
Please let me know if you have any ideas.
Thanks.

Okay, let me take a look at this.