Trail module in the particle system leaves a gap

Particle system trail gap - additional details and link to an example project on GitHub


Trail module in the particle system leaves a gap

Cocos creator v3.6.1
Platform Web

Example project on GitHub

Particle system trail gap GitHub Project

Steps to reproduce

  1. Add a sphere to the scene
    1. Add rigid body component
    2. Add a particle system as a child to the sphere
      1. enable trail module (find detailed settings on GitHub project or the screenshot attached)
  2. In the script
    1. apply an impulse to the sphere and observe as the trail leaves a gap (see screenshot)
    2. Make the camera look at the particle


  1. Screenshot of in-game simulation

  2. Settings of node with particle system

  3. Settings of particle system

1 Like

I am having the same issue. I tried changing multiple settings to generate one particle but that doesn’t change the result.

An issue has been created for processing.

1 Like

Reducing the physics simulation time step to a value much smaller than engine time step should solve your problem.