Supporting arabic fonts Label

Supporting arabic fonts Label

the arabic shows wrong on the Label .
So Cocos2d-x support arabic ?

this is how i add the Label .

Label* lab=Label::createWithTTF(“عربي”, “fonts/MyriadArabic-Bold.otf”, size.width/12);

thank you .

Using non-ascii character on source code could show you wrong result.
Try make text file, load it and assign text.

i did ,same result.
tried many fonts , when i use createWithSystemFont it works fine .i have no idea how to fix this .

Solved, by adding the font to the info.plist.

I have the same problem,

on Android, if I used createWithSystemFont It works as should,
But any other thing like Label::create OR Label::createWithTTF it fails

on Linux ( Ubuntu ) All methods fail.

Does anyone have a clue about that,

Thanks !

Can you create an issue for this?
Also it will be great if you can provide the font file.

Is there any fix for it yet?
Any way to have custom font support for Arabic without having to resort to the System Font?

Hi, I wrote a fix for Arabic and Persian support. It works 100% for Persian but may have issues with Arabic but are easy to fix. (I don’t know Arabic).

I cannot put link due to the cocos2d policy so in Github search for MohammadFakhreddin/cocos2dx-persian-arabic-support