Stuck at Importing Assets

Stuck at Importing Assets

I was having fun working with Cocoscreator and adding the SDKBOX plugins 1 by 1 when suddenly had issues with my workspace when I tried playing a Chartboost ad? Not sure what happened since the code seems correct. Now I can’t open it up.

I tried the ff.:

  1. Delete build folder - fails to load
  2. Delete local folder - fails to load
  3. Create new project and copy assets and library folder - fails to load

I’m pretty sure library should not be deleted from previous experience. I’ll check for other solutions (including rebuilding from scratch) but if anyone can help, that would be great.

Attaching console logs as well. (10.1 KB)

We can ask @yinjimmy to help us.

Hi, I’m sorry for wasting your time but I think I found out the issue.

For people who’ll encounter the same nature of this issue in the future:
Right click your Creator app> Show Package Contents>MacOS>Run Cocoscreator from there. Logs will appear and show which script/module causes the problem.

In my case, it’s because I’m a typescript noob so I tried doing some optional checking experiments thinking it’ll be the same as optional interfaces code. The actual line causing the issue in my script was


There was no warning when I did this and I was able to build the project to Android Studio. Upon launching the project from the creator app, that’s when it started locking at import assets though.

I didn’t think it was caused by my script since I didn’t expect it to cause the whole cocoscreator project not to load and just give me warnings in the console.

Anyways, thanks for the help @slackmoehrle! I’m having fun with creator and learning a lot of stuff from my own mistakes :smile:

1 Like

I had this issue before with CC: Cocos Creator Resources - (UPDATED October 2019)

Running the program as administrator fixes it on Windows :slight_smile:

Hi, thanks for the help though I already found the cause of this issue. I’m on Mac so this solution would be how Mac users would deal with it.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.