[Spine] #include <spine/spine-cocos2dx.h> file not found - SOLVED

[Spine] #include <spine/spine-cocos2dx.h> file not found - SOLVED
0.0 0

#1

Could you please somebody advice me why I can’t use Spine in XCODE (cocos2d-x 3.11 and 3.12)?
In Default, cpp template project is not possible to #include spine/spine-cocos2dx.h (file not found).
I can’t use Spine in all my fresh projects.

CPP-test from cocos 3.12 compiled fine and Spine tests work fine here. (including spine header file working OK).
I can #include <spine/spine-cocos2dx.h> also in OLDER cocos2d-x 3.4 without problem.

EDIT:
Solved 2:14 am by adding in the search paths: $(SRCROOT)/…/cocos2d/cocos/editor-support


#2

i have same problem.
can you explain in detail
thanks in advance


#3

go to settings header search paths

add

$(SRCROOT)/…/cocos2d/cocos/editor-support


#4

hi

im using linux with qtcreator as ide
where is the file that contains header_search_path?
i added “${COCOS2D_ROOT}/cocos/editor-support/” in " include_directories " in change cmake_list.txt file and build was complete but when run it then it crashed

sorry for my english