[SOLVED] SDKBOXPLAY not working after update

After updating sdkboxplay plugin I cannot connect to google play services anymore.
Here is the error I get:
GooglePlayServicesUtil: Google Play services out of date. Requires 10084000 but found 9452238
Please help :confused:

xoxo :smiley: it same issue as was described in SDKBOX cloud saves.


I think devs again added check for google play services version in wrong way - even if phone Google play services versions is smaller then bundled in app it still should work :frowning: u should check features supported not version.

How to fix this? thanks

I don’t know. Still waiting for someone from the SDKBOX team to advice…

you can pack the Google Play Services with

that will solve this issue.

Could you please explain a little bit further?

gps.zip (8.0 MB)

Please replace the <PROJECT>/proj.android/libs/gps folder, it should works.

The gps folder is in:
Replacing and downgrading it solves nothing. I still get the same error but this time with the new gps version:
Google Play services out of date. Requires 11010000 but found 9452238
As @energyy pointed, it seems that there is a really bad version check in the latest SDKBOXPLAY plugin code :confused:

It’s checking in Google Play Services, I’ll check how to fix this issue.

How to downgrade the Google Play Services on android device ?

My Google Play Services version on device is 11.0.55.

Could you please check the value of google_play_services_version in your project by:

$ grep "google_play_services_version" -rn  <PROJECT_PATH>

test.txt.zip (1.6 KB)
Here is the output with the default gps directory.

test2.txt.zip (1.3 KB)
and with the gps directory you gave me.

Do you know how to downgrade the Google Play Services in the android device ?

reproduce it !!!

I downgraded the Google Play Services to 4034530, very old version.

test with 2.3.14

 GooglePlayServicesUtil  W  Google Play services out of date.  Requires 10084000 but found 4034530

test with 2.3.13

 GooglePlayServicesUtil  W  Google Play services out of date.  Requires 9452000 but found 4034530

The warning/error comes form gps internal.
After sign-in several times, I get a hint.

It require me to upgrade Google Play Services on the device.


the ‘out of date’ error message just means that the version of Google Play Services on your device is not up to date. If you’re using a real phone this should resolve itself automatically.

@energyy What do you think? Whats the best practice?

Ok, knowing this is not the real problem helped me a lot. I’ve decided to debug with another device as this “Out of date” warning was the only thing my testing phone was showing. The other device produced more detailed output with an error pointing out that the Google Drive API for the application is disabled. So logging into the google play console and enabling the Google Drive API solves the problem and I’m again able to login. Guess this makes the thread SOLVED…
Thank you for your help guys!

1 Like

ref to [SOLVED] SDBOXPLAY Error (I/SdkboxPlay: Error connecting to play services, reason: 'SIGN_IN_REQUIRED(4)')

From 2.3.15, the cloud save will disable as default.