Hello, so i’m trying to integrate Fyber Offerwall into my app. I followed the instructions in the documentation and everything went fine except for the following issues :

1- When I click on the offerwall. it says “No Offers Available”. I thought this could be region related but that’s quite impossible as i’m running it on debug mode.
**the fyber listener indicates on logcat : D/PluginFyber: Offers are available (which is really weird and not true)
**when I exit : debug info: [Fyber] onOfferWallFinish: status(1)

2- second issue has to do with loading time during launch. you know that brief black-grey background when you launch a cocos2D game, well now it last 6sec+. thus it takes to long for my app to launch.

** heres the logcat on game launch :
08-14 21:25:52.445 27573-27635/com.games.mygame D/TcpOptimizer: TcpOptimizer-ON
08-14 21:25:55.282 27573-27615/com.games.mygame E/TrackingInfo: reqAdvertisingIdentifier Error:java.util.concurrent.TimeoutException
08-14 21:25:55.284 27573-27617/com.games.mygame E/TrackingInfo: reqAdvertisingIdentifier Exception:java.lang.reflect.InvocationTargetException


08-14 21:26:02.504 27573-27648/com.games.mygame I/System.out: (HTTPLog)-Static: isSBSettingEnabled false
08-14 21:26:02.505 27573-27648/com.games.mygame I/System.out: (HTTPLog)-Static: isSBSettingEnabled false

Offers are available means the offerwall widget is ok, just show the ui, I’ll cleanup the debug log.

how about without the fyber plugin ?

This is solved. I believe what i was doing wrong is init both Fyber and SDKBOXADS. i just removed fyber’s init. and everything seems to work just fine and both issues are solved.

I believe SDKBOXADS init’s fyber plugin itself. so initing fyber that twice was the source of the issue? anyway that’s how it got fixed. thank you

I’ll update the Fyber and SDKBoxAds documentation.
Thanks for using SDKBox.