[solved] No Sound in iOS at all

[solved] No Sound in iOS at all
0.0 0

#1

A bit confused, after a few hours of testing, without any results:
Cocos 3.13.1, iOS 8.4.1:
No Sound at all in test apps, ccp and js.
No errors in console, app says “Audio is playing”.
Tested on iPad & iPhone.
Test 7, CocosDenshion and Test 8, NewAudioEngine are deaf.

in comparison, playing a video thru browser gives me sound.

Anyone else having this prob?
cheers


#2

In which format are your sounds?

44.1 kHZ, 16 bit and wav / mp3 / aac should work on iOS.


#3

Hi framusrock, i did not check, as i assumed the files in demo apps test apps that came with cocos are supported…


#4

Ok, sorry for the most stupid post ever…
It was the tiny side-switch, that muted app sounds.


#5

Oh my goodness I am so glad you posted this. I was having the hardest time trying to figure this out and then I found your post mentioning the side switch on the phone. Mine is always down so I never even thought to look. Problem solved. But I am curios if there is a way to override that. Netflix seems to be able to… Not that I need to, just curios is all.


#6

:joy: Funny stuff