[SOLVED] Issues with Importing Plugins

[SOLVED] Issues with Importing Plugins
0.0 0



I’m having an issue with SDKBOX at the moment. I’m unable to use the GUI to import plugins. When I attempt to, I’m presented with the following error:

We’re using Cocos Creator 1.6.2 and cannot upgrade at this time, we are driving toward delivery.

If I attempt to use the CLI, I’m able to install to jsb-default projects, but I’m unable to install to jsb-binary projects, I’m shown the following error:

☁  jsb-binary [develop] ⚡ sdkbox import iap
  _______ ______  _     _ ______   _____  _     _
  |______ |     \ |____/  |_____] |     |  \___/
  ______| |_____/ |    \_ |_____] |_____| _/   \_
 Copyright (c) 2016-2017 SDKBOX Inc. v1.0.1.32
 test speed of hosts...
 - test host main: 254.83KB/s.
 - test host china: 37.03KB/s.
 choose the fastest server 'main', speed is 254.83KB/s.
 #FATAL: unsupported cocos2d-x major version
 Installation failed :(

If you could help me get past either one of these issues, it would be truly appreciated.

Thank you.

Edit: I’ve downloaded v1.8.1 just to check to see if it was just the old version, and I’m seeing the same error.

Solved: The latest version of the SDKBOX GUI does not have this issue. Close and reopen Creator to prompt an updated of the SDKBOX installer.


Just updated the SDKBox-GUI, would u plz open it and check it again?


I restarted Creator, the GUI did not update. It is reporting v1.1.4 and the issue persists.

Thank you.


@yinjimmy I can’t update the sdkbox from my creator…
It’s just asking me to reopen my GUI and then the update process continues all over again…
I’ve deleted my .sdkbox folder from system user and trying to launch GUI from creator.
And this is going on for the last two hours…


sdkbox gui will check update every day. can you reopen CocosCreator and try?


it’s strange, i delete my .sdkbox folder, and reopen creator, and upgrade success.

it stay at update SDKBox Installer, i guess it’s a netowrk issue. can you try again.

and another way:
you can run follow script in console.

python -c "import urllib; s = urllib.urlopen('https://raw.githubusercontent.com/sdkbox-doc/en/master/install/install.py').read(); exec s"

this script will install SDKBox Installer.


Is the syntax correct??
I’m getting this


my fault. should be:

python -c "import urllib; s = urllib.urlopen('https://raw.githubusercontent.com/sdkbox-doc/en/master/install/install.py').read(); exec s"

FYI: http://docs.sdkbox.com/en/installer/#get-the-installer


Opps… Still the same…
Two commands you sent are similar and the one in the FYI link too…
And I have python in my box.


your python version?




have a try

python -c "import urllib; s = urllib.urlopen('https://raw.githubusercontent.com/sdkbox-doc/en/master/install/install.py').read(); exec(s)"


New one now…



can you switch to python 2.7 for now, we need do more test on python 3.


Great that worked thanks alot


After the SDKBOX GUI updated to 1.1.5 it’s now working as expected. Thank you!


Problem with importing review plugin…
i can easily import other plugin though…


Would you please try it again.

Or download http://download.sdkbox.com/installer/v1/sdkbox-review_v2.3.17.7.tar.gz and put it into ~/.sdkbox/plugins/ fodler.



@yinjimmy Thank you sir… now i am able to install review plugin …