[SOLVED] Flurry plugin not recording app version

[SOLVED] Flurry plugin not recording app version
0.0 0

#1

SDKBOX version : 0.5.8.6

  sdkbox::PluginFlurryAnalytics::init();
  sdkbox::PluginFlurryAnalytics::setAppVersion("2.2");
  sdkbox::PluginFlurryAnalytics::startSession();

Looks like the app version is not being set correctly. I have waited for 24 hours for flurry to get updated and I have many users now on the latest version ( as per the google play statistics )

Any idea?


#2

Hello @abhinav

I will check on this and let you know.


#3

One more thing, I have been using Flurry for over 3 years now and when directly integrating with flurry sdk, I have always got the right version numbers automatically in flurry dashboard.

From the time I started using SDKBOX for flurry, no new version is being shown in flurry. I contacted flurry team and they advised me to explicitly call setAppVersion. That’s what I did couple of days back.

Hope this info helps as well.


#4

Hello @abhinav

Could you please check with the latest version of SDKBOX and let us know if you face the same issue.
Let me know, if it still doesn’t work.

Best,
Pabitra


#5

@pabitrapadhy

SDKBOX v0.5.8.12
Flurry plugin version : v1.5.2.6

This still doesn’t work.

This is what I did in my applicationDidFinishLaunching :

  sdkbox::PluginFlurryAnalytics::init();
  sdkbox::PluginFlurryAnalytics::setAppVersion("2.2");
  sdkbox::PluginFlurryAnalytics::startSession();

I don’t see any 2.2 version users in flurry ( Though I know from google play that there are lot of users who have this version )

One more thing, since the time I have started using flurry from sdkbox, only a single version is shown in flurry i.e. V2.0 Not sure where does this V come from. We don’t have this in our manifest.

Please get this fixed as this is causing lot of trouble in making sense of data coming in flurry.


#6

@nite Please enlighten me for the flurry set version behaviour.


#7

Let me do a test and let you know, flurry take 1 day for the events to show up, so it might take a while


#8

I have just integrated it in my project. It seems that when debug is enabled, its successfully sending the data…however, the Flurry admin console is not recording any data. Its been 12 hours now, but I sent flurry support an email, to see if they are indeed actually getting my events. I will update with what they say


#9

Just an update. Support from Flurry indicated that they haven’t recieved any events from my app. I suspected that the actual file name, containing the apkey is not being found. When installing it, it creates a file at the resource folder, however I saw some debug output entries saying that the file could not be found. I created a “res” directory and moved it into it, and it worked.

It seems that it has to be in a folder by that name to work. The install didn’t work. I wasted 3 hours getting this working. This may be the cause of other peoples problems


#10

@djvoracious

It’s strange the sdkbox_config.json that is created doesn’t need to be moved anywhere, it should be there inside the resources folder.

Could you send me your sdkbox_config.json file, so that I will have a look.
You could PM me.

Also, @abhinav

Could you also PM me your sdkbox_config.json !!

Best,
Pabitra


#11

@pabitrapadhy I will move it into the Resources folder, however, what may have happened (in my case) the project file didn’t include IOS in the target. Although it was included in the project (e.g. I could see it in the solution) when building, it wasn’t being included. Thats more than likely the issue here.


#12

Okay… Thanks @djvoracious :smile:


#13

@abhinav I might be facing the same issue. The Flurry logs are there every time I send an event, and of course the “sdkbox_config.json” is there and included between the copied resources. Still, no data of any kind at the Flurry’s panel. Did you find a solution to the bug?

EDIT: I stand corrected… Just saw a “ERR: Failed to load config for FlurryAnalytics”, sigh…


#14

Turned out that as I suspected, the sdkbox_config.json was included in the project file, but it wasn’t being included as part of the build target…just placing the file in the Resources folder (after including it in the IOS target) resolved the issue. Im flurrying away finally :slight_smile:


#15

Hi @lorenzochomp

Did you manage to make it to work ?
It seems to work for me.

If not, let me know about it.


#16

Hi @pabitrapadhy

I have a problem that I am facing now is that I cannot load my profile picture

I am just using https://github.com/sdkbox/sdkbox-facebook-sample/tree/master/cpp/Classes example, but replacing the me API call, with me/picture

void HelloWorld::onGetMyInfo(cocos2d::Ref* sender)
{
CCLOG("##FB %s", FUNCTION);

sdkbox::FBAPIParam params;
//PluginFacebook::api("me", "GET", params, "me");
PluginFacebook::api("me/picture/", "GET", params, "me/picture/");

}

There is an unhandled exception outside of my code. The crash kills the app.

Is this a known issue or am I missing a parameter?


#17

@pabitrapadhy Actually, I managed to get it by using the picture parameter too

sdkbox::FBAPIParam params;
params["fields"] = "picture";
PluginFacebook::api("me", "GET", params, "me");

All good my friend


#18

Can you double check your sdkbox_config.json there might be a version number there
If you want to use your app’s version as default, please remove that line in the config

There is a bug that the version in the config overwrites the version with setAppVersion function which we’ll fix in the next version


#19

@adhinav you can set AppVersion in sdkbox_config.json file

setAppVersion api just valid on ios,
you will get a message(“PluginFlurryAnalytics::setAppVersion set value in config file instead”) when you invoke “setAppVersion” on android


#20

I think that is the problem in my case. :slight_smile: Thanks a lot guys.