[SOLVED] Cocos Studio: Cocos Framework is not installed

Click here for the solution to this issue.

I’m using Cocos Studio and cocos2d-x 3.9 with the following installation layout:

cocos2d-x 3.9 is installed in the frameworks folder.

When I try to create a C++ project, no engine is installed:

The preferences menu item shows a message “Cocos Framework is not installed”:

I do have the the cocos2d-x 3.9 installed and I’m able to create projects, build and run them using VS 2015 just fine.

I can’t seem to get Cocos Studio to recognize that cocos2d-x 3.9 is installed. I’ve also tried with cocos2d-x 3.8.1 and cocos2dx 3.8, but none of those worked either.

I’ve checked other earlier threads (from about 6 months ago) and tried all the solutions posted in them, but none of them worked.

Does anyone have a fully working Cocos Studio with cocos2d-x 3.9? If so, can you please post what you did to get it working?


Try using the standalone framework with the standalone Cocos installer. That’s my 2 cents. As I noticed there are some serious problems with the framework that comes with the installers.

I got it fully working on mac today (needed libc++ and c++14 so I had to rebuild everything). I posted the relevant steps here, hope it helps:

@MatrixAndrew and @xcvr - thanks for your replies. I tried both your solutions and unfortunately neither solution worked by itself or in combination with the other.


However, I was able to solve the issue and I’ve written a detailed blog post at http://vijay.tech/talks/solved-cocos-studio-cocos-framework-is-not-installed-error/

Here are the actual steps I followed:

  1. Download and install Cocos for Windows V2.3.3 (the one without
    framework) to C:\Cocos

  2. Download and unzip cocos2d-x-3.9.zip to C:\Cocos\frameworks\cocos2d-x-3.9

  3. Manually create the following registry entries on Windows (64 bit):
    HKLM\Software\Wow6432Node\CocosFramework\InstallDir as a REG_SZ and set it to C:\Cocos
    HKLM\Software\Wow6432Node\CocosFramework\3.9\EngineVersion as a REG_SZ and set it to cocos2d-x-3.9
    HKLM\Software\Wow6432Node\CocosFramework\3.9\Path as a REG_SZ and set it to C:\Cocos\frameworks\cocos2d-x-3.9

  4. Create a file named version with the contents cocos2d-x-3.9 in C:\Cocos\frameworks\cocos2d-x-3.9

Cocos Studio will now recognize that cocos2d-x version 3.9 is installed and you’ll be able to create C++ projects in Cocos Studio.

Some issue on OS X. I installed latest Cocos 3.10. I manually installed SDK. But it doesn’t help form me. Any ideas what can be wrong?

@bibagames - Since your issue relates to OS X and my post is about Windows, you should create a new thread, so others who have the relevant knowledge can chime in.

Unfortunately, I can’t help you.

Thank you for your reply! :slight_smile:

Still not working with CocosStudio 3.10 in windows