Simple audio Engine Error

when we are putting sound inside cpp file getting error message.(CocosDenshion::SimpleAudioEngine::getInstance()->preloadEffect(“amazing.mp3”):wink:
we are using xcode Version 11.3.1 (11C505) and cocos version 3.17.2
Please find screenshot below

Please help me on this i am stuck since 1 week.

Can you show more of your code leading up to calling the sound? Where is it in your path? Res/?

Also cpp-tests has a working example :slight_smile:

Thank you for prompt response. While we continue to put sound we are having following issue and thread of sequence. I am attaching screenshot of thread and contain Res/ sound path.

We are stuck at this point awaiting for your response.

your screenshot says your mp3 file is in another folder besides just Resources/ also, make sure your audio is being included in the app itself. It looks like your Res/ is imported, but not a reference.

@slackmoehrle As per your suggestion I have tried to put .mp3 file on Res/ folder. still getting same error, Then i have upgraded my Xcode to version 13.0 and now working fine.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.